NETGEAR ReadyNAS 2120 not working

I have a ReadyNas 2120 with firmware 6.2.3. The problem is that I cannot access the web panel anymore. I have tried several approaches with no luck. Does anyone know how to solve this?. Fortunately, I got ssh access.
Oh, by the way how could LUNs be read as I can only access samba shares but not iscsi at all. Is it possible to get files from a LUN without using iscsi service?
Thanks in advanced.
LVL 6
Ludwig DiehlSystems ArchitectAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

andreasSystem AdminCommented:
What did happen if you try to access web interface?

Does it mean the ISCSI isnt running anymore too?

Did you try a firmware update before that went wrong?
Ludwig DiehlSystems ArchitectAuthor Commented:
When I try to access it, it shows this -screenshot-.png.
It seems as I cannot access any LUN
Yes. Before I had the same problem too
Ludwig DiehlSystems ArchitectAuthor Commented:
I have finally solved my problem. Here is the solution:

When starting readynasd service. These errors were logged:
Sep 08 14:50:12 SERVIDOR_NAS readynasd[9608]: readynasd log started
Sep 08 14:50:12 SERVIDOR_NAS readynasd[9608]: readynasd started. (restarted=0)
Sep 08 14:50:12 SERVIDOR_NAS readynasd[9608]: DB (main) schema version: 16 ==> 18
Sep 08 14:50:12 SERVIDOR_NAS readynasd[9608]: rndb_create() ==> 3 (116ms)
Sep 08 14:50:12 SERVIDOR_NAS readynasd[9608]: Error create table (db)
Sep 08 14:50:12 SERVIDOR_NAS readynasd[9608]: dba create failed

Open in new window


I finally found out that it was related to a kind of database, so I searched for it and fixed it with this:

mv /var/readynasd/db.sq3 /var/readynasd/db.sq3.bkp
mv /var/readynasd/event.sq3 /var/readynasd/event.sq3.bkp
mv /var/readynasd/smart.sq3 /var/readynasd/smart.sq3.bkp
systemctl restart readynasd

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ludwig DiehlSystems ArchitectAuthor Commented:
After doing, it worked like a charm!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.