VMware vSAN configuration

Hello Experts,

I have Configured a vsan in vmware esxi 6 by facking ssd and with proper network setting in 3 node cluster such that all communication is proper.
Issue is 3rd host is not contributing its HDD in vsan.
When creating a VM using vsan for data store, VM is not creating and giving error as
3rd host is not able to contribute to vsan. How do I fix this?

Any help is highly appreciated.

Best regards
Raghav.
LVL 7
RaghavIT SpecialistAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Is this a Lab or Production ?

Do you have SSDs or just HDDs that are being faked ?

Do all hosts have SSD (faked) and HDD ?

I have seen this issue in production, and it requires, the deletion and re-creation of vSAN.
0
RaghavIT SpecialistAuthor Commented:
Hi Andrew,
Thanks for the reply.
Its lab environment.
The HDD which is being facked as ssd and All host have fack ssd
I have already tried recreating vsan it gives same issue. Any other clue?  

Best regards
Raghav.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
If you remove the node, and re-add ?

have you used the command line tools, to check this ?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

RaghavIT SpecialistAuthor Commented:
Yes. It didn't work.
Can you give me a step by step approach to do this?  Thanks.

Best regards
Raghav.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
We can try, I've struggled with vSAN, doing the exact same thing.

can you post the output of

esxcli vsan storage list
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RaghavIT SpecialistAuthor Commented:
Hi Andrew,

Sorry for late response.

I had to do a clean install of everything. Made sure all the nodes are same in configuration.

It somehow worked after a clean install.

Thanks for your help.

Best Regards
Raghav.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.