Cannot install the vcenter server agent service. Cannot upload the agent

I have 3 host on Vcenter 5.5 Update 1. The first 2 host installed with ESXi 5.5 build update 1a and the last host installed with ESXi 5.5 update 2. The Cluster is has EVC enabled. I need to enable the HA for the cluster I have the error  Unable to install HA agent, error cannot upload agent on both host installed with ESXi5.5 update1a but the last host installed with ESXi 5.5 update 2 have no issue .
 
The first host have 2 VM as SQL Cluster that have share disk.
 
Then I disable the HA, there was an error stating error unconfiguring the vpshere HA on the host in the cluster. I attached the Event of the error on both enabling and disabling the HA.
 
I telnet port 902 on all the Host and the port are enabled.
 
I shutdown the VM and rebooted the host. The configuration issues still remains. Then I disconnect and reconnect the host to the cluster and previously I have enable ssh on the second host, after reboot the error shows  The configuration issues still showing error unconfiguring HA Agent with ssh is enabled.

I went to the security services, the ssh is disabled after reboot.

Anyway to resolve this problem? thanks in advance.
Vcenter-HA-error2.png
Vcenter-HA-error1.png
sweehanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Have you checked the FDM logs on the host, to check for the reason for failure.

I'm wondering if the ESXi OS installation disk is full, and it cannot install the agent ?

I was only at a site last week, and after an update of ESXi, to the latest version of 5.5 Update 2e, this was the cause.
0
sweehanAuthor Commented:
Hi

There's no record in the FDM log. I also test the upload speed to the host from vcenter via winscp. The file was able to upload to the host within few seconds.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Restart the Network Management agents on the host, if that does not work, then restart the host.

There should be FDM logs, fdm-installer.log in /var/logs
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

compdigit44Commented:
Hancock makes a good point... check your disk space. I had a similar problem install the HA agent a while back because of to little free space on the local datastore
0
sweehanAuthor Commented:
Hi,

The installation disk space is not full, It still have 80% of space. I had to schedule a reboot for both the host because both host are getting "general system error" and I can't vmotion the VM and control the host. Tried to restart management service but problem not resolved.

After I reboot, will try to enable HA back. Hopefully able to solved the problem.
0
sweehanAuthor Commented:
After reboot, the HA enable and able to install the HA agent properly. Will schedule a time to update the ESXi host.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.