Ubiquiti Nanostation M5 credentials recovery & basic setup

The factory default id & password  ubnt/ubnt won't allow me to login anymore.  Have tried pressing the
Reset button a few times in the hope I could reset it but the device did not even reboot when I press the
Reset buttons.

Q1:
a) do I need anymore on my Laptop's Win 7 to connect to this M5?  the laptop is now just next to it
    but don't think anymore of the SSIDs scanned appear to belong to this M5 though I could use
    LAN to do https://192.168.1.20/login.cgi
    (though the "https" is crossed-out in Chrome : I guess this is due to self-signed cert)

b) Also need some basic quick setup by this Tue evening for the long distance (no line-of-sight)
    access of around 8km.  The short brochure that comes with it doesn't have these instructions
sunhuxAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ugo MenaCommented:
If you already tried resetting your device to factory default values with the reset button and you can't access the unit, it is recommended that you to perform a TFTP firmware recovery.

*You will need the latest AirOS firmware file (you can download it from https://www.ubnt.com/download/#airmax-m)


Note: this guide refers to a PC running Windows, but is easly applicable to any other OS.

IMPORTANT!

    Do not switch off, do not reboot and do not disconnect the device from the power supply during the firmware upgrade process, as these actions will damage the device!

Recovery procedure (applies to AirOS devices running firmware v1.5 or higher)

Windows Users

   -First, power off the device
   -Configure your computer:
Windows PC's Ethernet must be configured manually with the following settings (under Network Connections):
    IP Address: 192.168.1.254, Subnet Mask : 255.255.255.0
  -Connect your M5 to the PC
   -Begin by pressing the reset button.
Keep holding, then power the unit on. Wait 8 seconds then release the button (if you want to reset the unit to factory defaults, wait at least 15 seconds). Signal LEDs will be lit indicating that the device is ready for recovery
  -Make sure that radio responds to pings (perform a ping 192.168.1.20 from a DOS window), if it does not, go back to the first step

 
   -Upload firmware image file .bin to 192.168.1.20, using a TFTP client software (binary mode).
Windows integrated command line TFTP client or download a third party utility to upload the AirOS firmware.

From Windows PC, you can use TFTP command line from a DOS window (START>>>CMD):
       
        Go into the same directory structure as the firmware (e.g., assuming that you have stored the image files in c:\firmware directory, type the command :cd c:\firmware) and enter the following (for help type TFTP -h) , e.g.:

        tftp -i 192.168.1.20 put XM.v5.5.10.24241.141001.1649.bin

-Signal LEDs will keep blinking one by one in 4 different colors during firmware upgrade. Wait for about 7-10 minutes (devices and firmware depending) - do not power off the device during the procedure!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.