Converting from VMware to MS Azure using Microsoft Virtual Machine Converter 3.0

I am trying to convert a VMware virtual machine to azure using the MVMC 3.0.  The tool appears to be running correctly and makes it through all of the steps until it reaches the analyze disk step. At this point the tool throw an error "could not enumerate volume with disk number 2".

I have seen other posts on line with these same error messages but no correct solution.


The vm that I am converting is basically a fresh install of 2008 R2 with nothing but patches installed and joined to our domain. I can not see why this would have failed. The error thrown in the log file is as follows.

VERBOSE: Microsoft.Accelerators.Mvmc.Engine.DiskCopyFailureException: The virtual disk(s) attached to the source virtual machine were not successfully converted to VHD(s) and copied to the workspace folder path. ---> Microsoft.Accelerators.Mvmc.Engine.VolumeMvmcException: Could not enumerate volume with disk number "2".

error.png
LVL 35
Joseph DalyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
what is disk number 2 ?

is it formatted in the VM ?

Does it exist ?
Joseph DalyAuthor Commented:
That's the strange thing there is no disk number 2.

 In disk part I have disk 0 and disk 1. Disk 0 is my os drive 50 gb and disk 1 is my 1tb vhd storage drive.

The only thing I can think of is that at some point in the conversion process Microsoft machine converter is trying to mount the disk from the machine I'm converting and that is disk 2.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
possibly, it's disk 1 and disk 2, e.g. your disk 0 and disk 1.

Disk 1 in the VMware VM is formatted NTFS, no strange partitions ?

when the conversion is being done, you should be able to see the temp disks on your conversion machine.
Joseph DalyAuthor Commented:
So I reran the conversion and the conversion disk was visible on the converter machine. Once again the conversion failed with the same error message. I started looking around on the server for event logs related to Microsoft virtual machine converter. There were none. However in the system log on the machine at nearly the exact time the process failed I was receiving partmgr error 58 events.

This error pointed to a collision with the disk uuid. Did a little bit of digging and while the uuids on my conversion machine were both different the uuid of the disk on the target machine happened to match with disk uuid on the target conversion server.

I had to use diskpart and change the uuid on my conversion machine so that when the converter attempted to mount the disk for analysis there was no uuid collision.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.