Why is this added to my web.config after I added a web servcie?

Hi, I'm using VS2013.
Why did it add my local development machine to the applicationsettings in the web config file after I added the java web service?  I then also get a socket exception referencing local host, my local dev PC wont' connect.  It's very confusing.  I want to connect to the web services APIs not my own local PC.  How to address this?  Thank you.

            msg      "System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it [::1]:8443\r\n   at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)\r\n   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address,
ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)"      string
web-config.txt
lapuccaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Fareed Ali KhanCommented:
I believe when you add the Java web service reference into your VS 2013 project your IIS or Owin was not running. But when you execute the Owin or IIS Java web server was not accessible.

Can you please check the port number on which Java web server is running and on which port IIS or Owin is running? If all trying to run on port 80 then it won't be possible. Change the java web server port number.
lapuccaAuthor Commented:
I looked up what is OWIN, http://owin.org/
It seems to be a standard interface so I'm not sure how to set it to run or if it's running.

The message from both VS2013 and the SoapIU both says the API server actively refused to connect at port 8443.  I have to find out from 3rd party vendor about which port are these java apis running on the apache server, yet to hear back from them.  But why is my code trying to connect to my local PC's 8443 port?  It says "Localhost".  That just blows my mind.  I gave it the correct wsdl url so shouldn't it try to connect to that apache server instead?
Thank you.
Fareed Ali KhanCommented:
Its because you have localhost in your web.config:

  <applicationSettings>
    <TestApi.Properties.Settings>
      <setting name="TestApi_SomeService_SomeService" serializeAs="String">
        <value>https://localhost:8443/XXXX/api</value>
      </setting>
    </TestApi.Properties.Settings>
  </applicationSettings>


Change localhost with appropriate server name.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lapuccaAuthor Commented:
I changed the local host to appropriate server name but get error saying Entrypoint not found exception and that it still says unable to connect to remote server.  I think the port number, 8443, it connects to is not opened.

Thank you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Services

From novice to tech pro — start learning today.