WMI Status - RPC Server Unavailable

Hi -

We are using the MS Assessment and Planning Toolkit  in order to determine the how ready we are for Office 365.  When I run the assessment tool it traverses our networking using Activity Directory as a guide.  About a dozen machines come back (some XP, Win 7, Win 8) with a full inventory of the machine.  The problem is that the inventory is not collected on the other 100+ machines.   Messages like "Failed - RPC Server Unavailable" or "Failed - Connection time out" are returned under WMI Status for all of the machines where the inventory failed. I cannot find a reason why it would work on a dozen machines and not work on the others.  All of the machines are in AD and are in the same OU.   Symantec Endpoint Protection is running on all of the machines using the same settings on all the machines.

Any suggestions are greatly appreciated.

Thank you!
swentwo1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zalazarCommented:
You might look at:
Are these computers in a different VLAN.
Is there are firewall blocking the connection.
Are the computers correctly registered in DNS.
Does the user account that runs the tool has the necessary (probably Administrator) permissions on all computers.
WMI is using port 135/TCP and the TCP high ports, you might do a port query on port 135 to these computers.
An easy way to do this is by using a telnet client (Windows feature).
From a command prompt (cmd.exe):
start telnet <ip-address or hostname> 135
If you can successfully connect to the computer the telnet session should stay.
If you can't connect it will give the message "Connecting To...."
swentwo1Author Commented:
The computers are not in different VLANs.
Symantec Endpoint Protection acts as our firewall on all computers.  Windows Fire Wall is not enabled.
I am using the network admin account for running the tool.

When I used the command

start telnet <ip-address> 135

a blank telnet window appears with a flashing cursor.  When I type the cursor moves, but I cannot see the text I am typing.  

Is this what I should be seeing?  How do I open port 135?
swentwo1Author Commented:
The computers are correctly registered in DNS.
Exploring SQL Server 2016: Fundamentals

Learn the fundamentals of Microsoft SQL Server, a relational database management system that stores and retrieves data when requested by other software applications.

zalazarCommented:
About telnet. Yes that's indeed what you should see and this indicates that you can connect to port 135/TCP of the destination computer. So this is ok.
What do you mean exactly with "How do I open port 135?". Port 135 is automatically opened by a Windows service.
Do you maybe use a corporate firewall within your network ?
Thanks for checking DNS registration.
swentwo1Author Commented:
We use a Sonic Wall Fire Wall between us and the outside world.   The assessment tool is using Activity Directory to guide it, so I would think there would be no reason for any of the traffic that that is created by the assessment tool would leave our internal network.  I am running the MS Assessment and Planning Toolkit from my desktop computer.
swentwo1Author Commented:
I was able to run a WBEMTEST on my personal computer, but when I tried it on any other computer it did not connect to the other computer.   It even failed on the computers that I successfully ran MS Assessment and Planning Toolkit on.
zalazarCommented:
That's kind of strange. To verify that you at least can connect and run a WMI query against the remote computers.
Can you run the following PowerShell command to test the WMI connection.
Start a PowerShell (powershell.exe) and then execute the following command.
Get-WmiObject -Class Win32_Service -Impersonation 3 -Filter "Name='Winmgmt'" -ComputerName <hostname>

Open in new window

Please replace <hostname> with the correct computername.
You should get some info back like:
ExitCode  : 0
Name      : Winmgmt
ProcessId : 836
StartMode : Auto
State     : Running
Status    : OK

Open in new window


If the connection fails then you could try to temporary disable the firewall on the remote computer and then test again. You could also try to temporary disable the firewall on the computer where you run the command from.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
swentwo1Author Commented:
The WMI query against the computers was successful.   A change in group policy to allow remote access allowed the Assessment tool to finally collect the needed data.

Thanks for the great troubleshooting methods.
zalazarCommented:
Good to hear that you found the solution.
Thanks very much for the grade.
AkulshCommented:
Swentwo1 wrote - "A change in group policy to allow remote access allowed the Assessment tool to finally collect the needed data."

I wish he had given some details about the GPO used for remote access. Thanks.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.