Error external port is duplicate

Setting up WD My Cloud Mirror for remote access...
WD My Cloud Name   NAS1
WD Mycloud IP  192.168.1.2..
GW   192.168.1.254

I have router ports forwarded to 8080 and 8443...pointed to 192.168.1.2

When I use the default WD ports...
Ext port 80
Int port  80
I get Status FAILED and an error  external port is duplicate...

When I use the customize WD ports
Ext port 8080]
Int port 8443
I get status FAILED and the error external port is duplicate...

I have gone thru the setup of the WD My Cloud several times...I have read and read the
setup instructions and I believe I have all the settings correct...

But I do not understand this error message   External port is duplicate.....

Can anyone help me out...???

If I cannot get this WD system to work...Is there another
way I can access the WD My Cloud remotely...???

Many thanks...
LVL 2
Steve MutchlerIT TechAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CompProbSolvCommented:
Is there any chance that there is another device at that IP address?

To test, try the following from a workstation:
start
run
cmd
ping 192.168.1.2

See if you get replies (you should).

Disconnect the My Cloud and run the ping command.  If you get replies then something is already using that address.
Steve MutchlerIT TechAuthor Commented:
CompPronSolv...
Thanks for the reply...
I just set the network up a couple weeks ago...
The only static IP's I have are 192.168.1.2...   5... and   56....

I have not pinged the IP...but I will tomorrow, Wed when I get back to the client and let you know...
CompProbSolvCommented:
Looking to the future.... does your DHCP range exclude those addresses (.2, .5, and .56) that you are using statically?
Need More Insight Into What’s Killing Your Network

Flow data analysis from SolarWinds NetFlow Traffic Analyzer (NTA), along with Network Performance Monitor (NPM), can give you deeper visibility into your network’s traffic.

Steve MutchlerIT TechAuthor Commented:
Yes...DHCP runs from 60 to 100...
Couple more hours before I get to my client...
I'll post results...
Steve MutchlerIT TechAuthor Commented:
Ok...at client right now...

With NAS disconnected...no return ping 192.168.1.2...
So...I so NOT have duplicate IP's set up...

double checked my DHCP and it's actually  .64 thru .230...
Well out of the range...

Sending info to WD...asking them to help...

I will post any results from them...
Many thanks...
CompProbSolvCommented:
Is this accessible when on the same network?
CompProbSolvCommented:
I would suggest the following:
Reset the MyCloud to default ports (http: is 8080 and http: is 8443)

Confirm that you can get to the device by opening a browser on the same network and pointing it at http://192.168.1.2:8443 and also try https://192.168.1.2:8080.

Assuming that worked, set up port forwarding on your router for ports 8080 and 8443 (same internal and external on both).  Test access by pointing a browser from another site to http://<your external IP address>:8443 and to http://<your external IP address>:8080.
Steve MutchlerIT TechAuthor Commented:
I have reset the MyCloud ports several times...
But I will do it again...
I CAN access the device while on the SAME network...

Question is...after re-forwarding the router ports again...to I test access by ext IP:8080 etc
from the LOCAL network or from a foreign network...???

I will do this tomorrow....
Steve MutchlerIT TechAuthor Commented:
BTW...
Thanks for staying with me...
Steve MutchlerIT TechAuthor Commented:
A little more explanation...

I CAN access the NAS with IE and 192.168.1.2...
I can also MAP the drive...

When I access by IP WITHIN the same network I
get the MyCloud access screen which I also get from a foreign network...

Difference is I CAN log in thru MyCloud access within the local network...
I cannot LOG in from a foreign network...
Hope this helps...
Steve
Steve MutchlerIT TechAuthor Commented:
Just tried connecting from MY local network...NOT the network where the NAS is located...
I use   http://externalP:8080
I get the error...
Cannot connect to the http://extIP:8080 network...
CompProbSolvCommented:
If you can connect locally (as you have said) and you cannot remotely then it just about has to be a problem with port forwarding in your router.

Can you give a screen shot (use a smart phone if needed) of the port forwarding configuration screen on your router?  If it shows your external IP address anywhere then you may want to block that part out of the picture.
Steve MutchlerIT TechAuthor Commented:
Will do...
Steve MutchlerIT TechAuthor Commented:
Ok...bad news...
http://externalIP:8080 from within the local network...will NOT connect to the NAS...

External IP is determined from www.whatismyip.com...I get 162.224.xxx.xxx

I have the NAS mapped as a drive...and I can access the NAS locally for any PC...

But I cannot access the NAS thru the 8080 port...I'm getting some images and will post those soon...
CompProbSolvCommented:
Depending on router and settings you may not be able to get to internal devices using the external IP address.  I'd not worry about that.

Are you still able to access the NAS drive through the web interface using the local IP address?
Steve MutchlerIT TechAuthor Commented:
Here are screen shots of MyCloud and router...
MyCloud-for-MY-logon.docx
CompProbSolvCommented:
OK... this is making more sense now.

I believe that the MyCloud is trying to configure your router using uPnP, which may not be enabled.  I'd set the MyCloud to 8080 internal and external for HTTP and 8443 internal and external for HTTPS on the Port Forwarding Settings screen.

I would also configure the Cloud Access Connections screen as shown in the attached picture that I took from Western Digital's site.  I suspect that this is the real issue.


I would assume that it can NOT reprogram your router for you, but it does seem to be configured correctly.
MyBook.jpg
Steve MutchlerIT TechAuthor Commented:
When i first set up MyCloud...I had the option of MyCloud configuring the router ports automatically...uPnP
I assume....I ran that option and later when I checked the router ports I noticed that 8080 and 8443 were NOT set up in the router...so I forwarded those ports manually....

Referring to the image right under  "MyCloud Port settings"...
Currently I have HTTP set up for 8080 both internally and externally...
Once I hit "SAVE"...then I do NOT have the option going back to this screen and setting up HTTPS...I can choose one or the other...
So I chose HTTP...

In the jpg you enclosed...I have gone thru all the various instructions...and that particular image is NOT
available on this MyCloud device....I think the jpg you refer to is an earlier version of what is now the
MyCloud Network settings image that I put up...

I also believe I have the router ports forwarded correctly...the forwarded port to RDP Keith 59 works perfectly...


Many thanks for all the help and sticking with me...
If you have any more ideas or need some other info I can provide...let me know...
CompProbSolvCommented:
I've got to get back to the conclusion that if you can get to it locally with http://<local IP>:8080 and if port 8080 is properly forwarded (as you picture seemed to indicate), then it should be accessible from a computer at a different location with http://<Exernal IP>:8080.

If I were troubleshooting this locally, I'd grab another router (several lying around) and test with it.  That is, configure the LAN side of the temporary router as 192.168.1.1, and connect the MyCloud to a LAN port on it, configure the WAN port to the same as your router is using.  I'd then set up a computer with a static IP address on the same subnet as the WAN port on your router and connect the two together.  That gives you something to work with that doesn't disturb your existing network, other than the MyCloud not being available to anyone while you do your testing.

Set up port forwarding on the test router and see if you can access the MyCloud from the WAN side of the router.  If you can get that to work but not on the main router, there's either an issue with the router or with the ISP.

The ISP......   any chance that they are blocking ports?  That could be the issue!

I set up VNC frequently for remote access.  I'd look at setting up VNC on a computer and then do port forwarding to it and confirm that it works through the router.  We can go different directions with troubleshooting if that doesn't work.

Following the suspicion about the ISP, change the port to 80, set up port forwarding, and see if that allows access to the MyCloud.
Steve MutchlerIT TechAuthor Commented:
I doubt it's the ISP...this is a Uverse connection with a static IP...one other port I have forwarded in the router works  correctly...

I did try to set the MyCloud up on ports 80 and 443, which should be open by default in the router...and I still
could not access MyCloud  from a foreign network...

I will try your idea with a spare router next week...Probably Wed...so it will be a few days before I can get back to you with results...

Thanks for the help...
CompProbSolvCommented:
If you can disrupt internet access on the LAN for a few minutes, this might be a better test.

Let's assume that your present router is configured with a WAN address of 162.224.1.1, a net mask of 255.255.255.252, and a default gateway of 162.224.1.2.  Set up a computer with the following LAN settings:
IP address 162.224.1.2
Net Mask 255.255.255.252
Default Gateway 162.224.1.1

(Note: substitute the actual WAN address and Gateway for the values listed above and elsewhere)

that is, swap the IP address and the Default Gateway between the router and the computer and use the same net mask.  If you connect the network jack on the computer to the WAN/Internet jack on the router (this is what will disconnect the network from the internet), then your computer should be accessing the LAN as if it is on the internet trying to get through the router.

Try to access the MyCloud with http://162.224.1.1:8080.  If it works here and not when connected to the internet, it is a problem outside of your network and router.  That is, you likely have some issue with the ISP.

If it doesn't work, then you've got an internal issue.  Assuming that it works when accessed locally on the same port then it must be something going on in the router.
Steve MutchlerIT TechAuthor Commented:
I like this idea...
We will be working on this on Tuesday...

Let you know results later...

Make sure I understand...
Check router WAN port with www.whatismyip.com...put that IP into my comptuer...
Unplug the WAN port and plug in my computer with the WAN IP...
Same net mask as being provided by ISP..and the same gateway...

Now try http://"fake external IP" :8080...

If I get in I got an ISP issue...

If I do NOT get in...I got a router problem...
CompProbSolvCommented:
Almost.....
The IP address you will get from whatismyip.com is the external address of the router.  You also need the default gateway address that the router uses.  It would likely be easiest to retrieve that from the router management interface.  While you are there you can get the external address (same as whatismyip provides).

The gateway and IP addresses should be swapped between the router and the computer and the net mask should be the same.

For example, if the router's WAN address is 162.224.1.1 (that is what you will see by whatismyip.com) that should be used as the default gateway on the computer.  If the router's default gateway is 162.224.1.2, that should be used as the IP address for the computer.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Steve MutchlerIT TechAuthor Commented:
Got it ...thanks...
Steve MutchlerIT TechAuthor Commented:
CompProbSolv...
My apologies for not responding MUCH faster than this...
I got the problem solved...
WD My Cloud has TWO locations for entering port #'s...
IF you enter port #'s in BOTH locations you get the error i was getting...
If you enter the port #'s in the only correct location...everything works just fine...

The 2 places to enter the port #'s are in totally different screens on the panel...
they appear to be unrelated....

It took a while but we got it...thanks to your help...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cloud Computing

From novice to tech pro — start learning today.