SSMS Database Diagrams error

Hi, I'm using sql 2012
I turned off all sql services, except for servcies of SQL SERVER, SQL SERVER VSS WRITER and SSDP DISCOVERY.  I then open SSMS, and the diagram I previously created for this database is not there.  I right click on the Database Diagrms node, menu shows options for "New Database diagram" and "Install diagram support"

Selecting either of these 2 menu options would give me the following error message.  However, when I examine the property of the database, it shows me already is the owner of the database.  

Is there a sql service that I need to turn back on ?  How t fix this?  Thank you.

TITLE: Microsoft SQL Server Management Studio
------------------------------

Database diagram support objects cannot be installed because this database does not have a valid owner.  To continue, first use the Files page of the Database Properties dialog box or the ALTER AUTHORIZATION statement to set the database owner to a valid login, then add the database diagram support objects.

------------------------------
BUTTONS:

OK
------------------------------
lapuccaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Deepak ChauhanSQL Server DBACommented:
Follow these steps. run the alter command first

ALTER AUTHORIZATION ON DATABASE::<YourDatabaseName> TO sa
 GO
 
 Select your database >> Right Click >> Select Properties
 Select FILE in left side of page
 In the OWNER box, select button which has three dots (…) in it
 Now select user ‘sa’ or NT AUTHORITY\SYSTEM and click OK.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lapuccaAuthor Commented:
Deepak,
I followed your instruction except the alter command, which I didn't run, and it still worked! It bought back my diagram and I'm able to edit the diagram.  So what happened to my diagram before?  Is it because I turned off some SQL services?  I want to free up resources on my local dev pd so I turned off most sql services I dont' need.  Is this the cause of my problem?
Thank you.
Deepak ChauhanSQL Server DBACommented:
I dont think Service turned off is the cause. In my it happened when i migrated the database from SQL 2000 to 2005 but just changing the compatiblity lever from 80 to 90 it was resolved. But second time in SQL 2008 when i restore the database from one server to another with same compatiblity level it through the same error I checked the database property and found that owner which was set does not exist onn the server, i changed the owner and it got resolved.

I dont know what is your case, but i think if you are sysadmin on the server you might be able to install initial component.
lapuccaAuthor Commented:
I didn't change or migrated the database.  It's odd but hopefully it wont' happen again, thank you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.