ASUS Laptop P key generates an asterisk

My ASUS laptop running Win 8.1 has a keyboard problem where the P key generates an asterisk, the 0 key generates a slash (/), semi-colon is a dash and slash (/) is a plus sign.

I have looked in control panel -> keyboard but can't figure out what's going on. This problem appeared today. Rebooting does not appear to correct this behavior.

Is there a way to reset this?

Thanks.
ou81aswellAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
This is a hardware problem in the scan lines for the keyboard.  Either the keyboard (very likely) or the keyboard controller (not very likely) is defective.  To troubleshoot, swap the keyboard with a known good one and see if the problem goes away.

If the system is under warranty, this would be a covered defect.
0
ou81aswellAuthor Commented:
Thanks. What's the quickest way of swapping my laptop's keyboard? Is there a spare one hidden somewhere?
0
JustInCaseCommented:
What version of laptop?
You just turned on Num Lock, and your laptop don't have numeric keypad.
Num Lock On and OffTurn off Num Lock should solve your problem.
:)
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

Joe Winograd, Fellow&MVEDeveloperCommented:
Your keyboard is probably not defective. Likely, it's in NumLock mode. Many laptops do this. It allows you to have a numeric keypad. Look for a NumLock key and tap it to turn off NumLock mode (it's a toggle — one tap turns it on, the next tap turns it off). Regards, Joe
0
Dr. KlahnPrincipal Software EngineerCommented:
Good catch.  I never use NumLock on a laptop.
0
nobusCommented:
you can test in several ways :
-test with an  external keyboard will show if the problem happens too; if yes, it is a software problem
-test the keyboard when booted from a live cd , like knoppix : http://distrowatch.com/table.php?distribution=knoppix
0
Michael-BestCommented:
Depending on Asus model
Press Fn or Shift + NumLock to toggle the key assignment.
0
ou81aswellAuthor Commented:
Thanks guys.  I have an ASUS Q301L (read from label on the back). I bought it 14 months ago at a Best Buy. It does not appear to have a numlock key.

I have attached a photo of the keyboard.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Photo not attached. If you need help in embedding/attaching images, here's an EE article explaining it:
How To Embed Screenshots in Posts

Update: I found your Q301L keyboard image elsewhere. Even though it doesn't have a NumLock key, NumLock got turned on, maybe by a program or maybe by an external keyboard — if you connected one. If you did, connect it again and turn off NumLock. Another way is to open up the on-screen keyboard. I don't have your computer, but a web search indicates that you can get the on-screen keyboard by typing OSK at the start screen. When you get the on-screen keyboard, click Options and you should find the numeric keypad/NumLock — turn it off. Regards, Joe
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JustInCaseCommented:
Save this and execute it once.
If you do it twice it will be just as where you started. :)
3x should be OK
NumLock.vbs
0
ou81aswellAuthor Commented:
I must have hit browse to locate the image but neglected to click on the Upload button. Sorry about that.

Your explanation sounds quite feasible since when at home, we use a Targus USB 3 dock connected to a full size MS sculpt comfort keyboard and mouse.

I will try and find a keyboard to toggle the numlock key. We discovered that you can enter a P by holding down the FN key and pressing P. In fact, if you hold down the FN key on the other problematic keys, you get the correct result. We can live with this until we get home.

Will report back when I get the chance.

Many thanks for your helpful comments.
0
JustInCaseCommented:
Just run script and you don't have to wait to come home.
:P
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Another approach is to run this VBScript:

set WshShell = CreateObject("wScript.Shell")
WshShell.SendKeys "{NUMLOCK}"

To give credit where credit is due, that code is from here:
http://www.tomshardware.com/answers/id-2115797/asus-vivo-keyboard-displaying-incorrect-characters.html#14271972

Regards, Joe
0
JustInCaseCommented:
Code is not from there. :)
It is easy to paste code in search engine - it will find some match.
Actually it is from here to give credit where it due.
But you can find it on many locations when you paste code into search engine.
It is some time in my bookmarks in the case I need it, along with this one for other keys.
:)
0
Joe Winograd, Fellow&MVEDeveloperCommented:
To be clear, I didn't paste that code into a search engine. I hadn't even looked at your attached file until now. I found that code when I was searching for a picture of the keyboard. In terms of sending keys more generally, I use the excellent (and free!) AutoHotkey. Its list of Keys, Mouse Buttons, and Joystick Controls is here:
http://ahkscript.org/docs/KeyList.htm

Regards, Joe
0
ou81aswellAuthor Commented:
Back home now. Connected the laptop to the dock and toggled the external MS Sculpt keyboard's NumLock and presto! Problem solved.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
That's great news! Always nice when it's a simple fix. :)
0
Member_2_7969006Commented:
Yeah Joe Winograd's solution and explanation works.  I have Asus Zenbook on Windows 10 July 23, 2016.  I had exactly the same key morphs as the original question - p becomes asterisk; zero becomes slash; slash becomes plus.  I found the on-screen keyboard and sure enough it showed NumLock as on.  Turning it off fixed the problem.  Saved me from switching out keyboard, searching for malware, etc. etc.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Glad to hear that, Member_2_7969006 — thanks for the post! Regards, Joe
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.