Outlook 2013 Archive gap

Hi,

Ok it goes like this:

1. Iv'e tried archiving in outlook 2013 (an Exchange account), defining the archive to apply on anything before June 2014 - the archive folder was created but nothing moved there.
2. I've concluded that may be for some reason the "Last modified date" field for all mail was the cause & so I've added the registry key ArchiveIgnoreLastModifiedTime = 1 under HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Preferences (as per the suggestion here: http://www.howto-outlook.com/faq/archivenotworking.htm).
3. I've run the archive again but this time I've decided to apply the archive for anything before January 2015 (it's actually a client & he's changed his mind, anyways..).
4. The new archive folder was formed & mail did move there but that mail was only from between June 2014 to January 2015.

It's like Outlook decided that everything before June 2014 was already archived in the first archive I did - which is of course not true!
Now the guy has in his Exchange mailbox mail up till June 2014 & mail after January 2015 with the gap in between moved to the archive.
It doesn't matter how many more time I run the archive to apply to anything before January 2015, all mail before June 2014 is still left in his Exchange mailbox & isn't moved to the archive :(
Please help
meirgilAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Where is the mail you wish to archive?  If in folders (other than Inbox), you need to check the properties of each folder (right click on the folder) and look in the Auto Archive tab. Make sure Archive is selected for each folder. Do this for Inbox as well just in case. Once every folder is set for archiving, it should archive .

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
meirgilAuthor Commented:
Hi,

Thanks but I tried now to select Archive under the Auto Archive folder for specific folders just to try & it's the same thing :(
JohnBusiness Consultant (Owner)Commented:
I use Outlook 2013 and I archive it

Check the folder properties again (to be sure) and then close Outlook.  Now open Outlook and reset all the Auto Archive properties in Advanced Options. Make very sure you have UNCHECKED the options to Delete expired items and to Permanently delete old items.  Then Apply to All Folders and check again.
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

meirgilAuthor Commented:
Thanks John, I followed what you said now & tried it but it just doesn't archive anything older than June 2014 still - it's like the first archive I did (which was set to archive anything older than June 2014 but didn't move any mails to the archive) somehow marked the mails older than June 2014 as archived already or something
JohnBusiness Consultant (Owner)Commented:
I am not sure what has happened so you probably need to look at the Exchange settings (and I am not an expert in Exchange archiving).
meirgilAuthor Commented:
I think it's important to understand what happened:

1. An unsuccessful attempt to archive anything before June 2014 (outlook created an archive but put nothing in it).
2. A solution we gave by adding "ArchiveIgnoreLastModifiedTime = 1" to the registry.
3. A second attempt to archive anything before January 2015 (resulting with a new archive that somehow only contains mails from between June 2014 & January 2015).
4. No matter how many more attempts to archive - mails from before June 2014 would stay in the mailbox & not archive (as if outlook thinks it's already been done on the first try or something).

Thanks in advance!
JohnBusiness Consultant (Owner)Commented:
I am not sure how many machines you are dealing with, but a workaround is to just move the mail manually. I have done this very infrequently but it does work. Once cleaned up, archiving should be fine.

A solution we gave by adding "ArchiveIgnoreLastModifiedTime = 1" to the registry

Sometimes registry changes have unintended consequences. I avoid such changes if I can.
meirgilAuthor Commented:
Thanks but would be a lot of work (many many folders & sub folders) on a high profile system (an executive here) - really very last resort option!
JohnBusiness Consultant (Owner)Commented:
For one or two emails, I see that they don't ever archive. Since archive works, I do not why several emails get missed. I can see that, when it happens, the emails no longer get archived. I look through my main folders from time to time and move errant emails into archives.

You can repair an Exchange email file but I do not know if that will help.
meirgilAuthor Commented:
Hi John,

As I said - going manually through the emails is currently not an option.
May be someone knows what can cause this\how to resolve it?
Pleeeeease? :(
JohnBusiness Consultant (Owner)Commented:
As I noted above, if somehow the email fails to archive for some reason, then it probably not possible to make them archive.

So your user may have to leave the emails where they are.

This is Exchange, and so you may wish to investigate repairing the mail file to see if that works.
meirgilAuthor Commented:
You also noted it may not help John & that you don't know why this happens when it does...
May be someone knows what can cause this & then how to go around it?
Please someone who does know what the reason might be? Please?
JohnBusiness Consultant (Owner)Commented:
Here is an Outlook how-to that for the most part confirms the suggestions I have offered plus a registry check (be careful). Check through and see if anything there might be re-tried. Otherwise I am out of ideas.

http://www.howto-outlook.com/faq/archivenotworking.htm
meirgilAuthor Commented:
John, that's actually the very same link I've mentioned on my first post (have you read it?) :(
As I said - I did the registry change & it worked but only on the gap of dates between the first non successful archive & the newly defined one..
JohnBusiness Consultant (Owner)Commented:
I read through the first time and I was merely suggesting to go through it again. I do not think there is any other way.
JohnBusiness Consultant (Owner)Commented:
Try the various Exchange Mailbox Repair possibilities and see if they bear fruit.

https://technet.microsoft.com/en-us/library/ff625226(v=exchg.150).aspx
Iain MacMillanIT Regional Manager - UKCommented:
some emails will not archive if they have been set to a different security/sensitivity setting, like private and/or encrypted perhaps.  i have had to manually move emails in this case by usual drag/drop method.

also once they have these PST files, it's important they make sure they get backed up, as they won't be on the server, unless you are doing server based archiving, in which case you need to make sure the backups are good and tight to prevent data loss.
meirgilAuthor Commented:
The reason I believe the mail from before June 2014 has been marked as archived already & thus will not re-archive is that anything newer than June 2014 will still archive without a problem.

As I said - our first attempt was to archive anything before June 2014, Outlook showed it's doing it, an archive folder was opened but nothing moved into it & then a change in the registry(*) allowed archiving but nothing before June 2014 as Outlook seems to think it's already been made!

If anyone is willing to dive a bit deeper & really try to help me understand what happened & how to go about it I'd be more than grateful & would check & report back any question you may have - waiting for someone serious to really try to help out..

Thanks in advance.

*As I wrote before, made the registry change offered here: http://www.howto-outlook.com/faq/archivenotworking.htm after which archiving actually moved items into the archive folder but nothing before June 2014 (the first attempted archive which Outlook reported as done..)
May be the solution lies in changing something to do with mails being marked as "Archived" & reverting them back or something?
Iain MacMillanIT Regional Manager - UKCommented:
short of moving them manually i cannot find a way of 'resetting' the archive flag on a message.  Its been a known issue before as per this article, but this applies to older Outlook versions -- https://support.microsoft.com/en-us/kb/295657

does the user have any other devices that may have links to the mailbox, they may need to have the account/link removed as a possible cause of stopping the function (long shot).  

Also if you are using Cached Mode, you might want to turn off and see if that resolves anything (and delete the OST file in the user's Outlook folder in Local Settings).  I assume the archive PST's are linked to the client just now, does ScanPST give them a clean bill of health?

Have you tried the Clean-up tools under FILE>>MAILBOX CLEANUP?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.