Exchange 2003 - Office 365. Still using Exchange 2003 for relay

Previously used Exchange 2003. Installed Exchange 2010, moved mailboxes to 2010 and then migrated to Office 365. Redirected MX records, Purged mailboxes on Exchange 2010. Everything is working fine with one exception.

Devices/Software were still using Exchange 2003 to relay e-mail. I set up a new SMTP server and moved everything to use this. However, I still have one web service that is using Exchange 2003 to relay e-mail - I'm not a developer, I can't modify the code. I'm waiting on the developer to modify the code. In the meantime, messages that are sent from the web service, via Exchange 2003 to previously internal e-mail addresses are failing.

Error logs are pointing to an NDR being created:

A non-delivery report with a status code of 5.4.6 was generated for recipient rfc822;user@domain.com (Message-ID  <2079311841.1492.1433304180817.JavaMail.tzweb@ACTZW02>).  
Cause: A forward loop was detected by the categorizer. This is a common hosting configuration problem caused when someone uses the provisioning tool to create a contact in one organization unit and creates a user in a different organization user that share the same e-mail address.    
Solution: Verify that you do not have a user in organizational unit and a contact in a different organizational unit that have the same e-mail address.

https://support.microsoft.com/en-us/kb/324732

The KB says I should clear "This exchange organization is responsible for all mail delivery to this address" box. But, unfortunately, I can't do that because it's the Primary SMTP address.

Any suggestions on how to fix this?
KThraceAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KThraceAuthor Commented:
I should add that I also made all users Mail Enabled with the correct ProxyAddresses. Using Directory Sync, so I can manage the users e-mail addresses etc from Active Directory which will then sync to O365.
0
Delphineous SilverwingGood Ol' GeekCommented:
Have you tried configuring the Exchange 2003 SMTP connection to use a smart host, pointing to the O365 SMTP gateway?
0
KThraceAuthor Commented:
I tried setting the SMTP Connection to use the real SMTP server as a smart host, but it didn't work - I'm assuming because Exchange 2003 still thinks it's responsible for e-mails delivered to this domain and so it ignores the SMTP relay...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Delphineous SilverwingGood Ol' GeekCommented:
I am interpreting that all mailboxes are removed from the environment, correct? Everyone was moved to the hosted system?

If so, set a local e-mail domain (contoso.local for example) as the default domain and then uncheck the "This exchange organization is responsible...".
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KThraceAuthor Commented:
Yes, all mailboxes are in the cloud and have been disconnected.. All users have been set to mail enabled users.

I JUST now in the recipient policies added a new primary SMTP address that is different from the current domain and set it to primary. I unchecked "This exchange Organization is responsible for all mail delivery to this address" and then unchecked the SMTP policy. I then disabled the recipient update services. I did a test and it seems to work. I'm just concerned that in a few hours something is going to break...
0
Delphineous SilverwingGood Ol' GeekCommented:
<fingers crossed>
0
KThraceAuthor Commented:
So far so good...
0
Delphineous SilverwingGood Ol' GeekCommented:
Excellent!
0
KThraceAuthor Commented:
Looks like we're good! Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.