When I use Powershell to add -GrantSendOnBehalfTo permissions, command runs, but no settings are modified.

I'm trying to enable one user (BBBB) to be able to send emails from another users account (CCCC). In the past, I've given other users (4 of them) the same ability using Powershell with Office 365. But now, while the command runs successfully, the change is not made.

I run the command: Set-Mailbox CCCC -GrantSendOnBehalfTo @{add="BBBB"}

and I get this message: WARNING: "The command completed successfully but no settings of 'CCCC' have been modified."

I've tested it with other user combinations and the same thing happens. I've also checked that I can make other changes like adding or removing FullAccess permissions to mailboxes and adding and removing access to individual calendars and those work fine.

I'm stumped as to why the command seems to run, but won't effect the change.
mhoughtelingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

K BCommented:
0
Thomas WheelerCommented:
That would say it has already been set. Did you run get-mailbox bbbb and check the value?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mhoughtelingAuthor Commented:
KB - I've played with the syntax by including -identity and using the email address vs. the username. Same thing.
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

mhoughtelingAuthor Commented:
Thomas - I have confirmed that the user already did not have permissions nor does he have permissions after I run the command using this lovely query that I've found.

Get-RecipientPermission  CCCC | Where { ($_.IsInherited -eq $False) -and -not ($_.Trustee -like “NT AUTHORITY\SELF”) } | Select Trustee, AccessControlType, AccessRights

as it shows the 4 other users I've given access to.

get-mailbox bbbb just gives the Name, Alias, ServerName, and ProhibitSendQuota.
0
K BCommented:
why the extra characters... just use upn

Set-Mailbox -Identity John -GrantSendOnBehalfTo Suzan
0
K BCommented:
Set-Mailbox -Identity John@contoso.com -GrantSendOnBehalfTo Suzan@contoso.com

just like that.
what are your results
0
K BCommented:
Add-RecipientPermission (send-as)
Add-MailboxPermission (full access)
Set-Mailbox (send on behalf as)
0
mhoughtelingAuthor Commented:
It's been a long day. I wanted to add SendAs permission so yes, GrantSendonbehalfTo was already set; I wanted to see it as SendAs.

Thanks guy.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Powershell

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.