A mailbox couldn't be found for Exchange 2013

Here is the error when going to domain.com/owa :

:-(
something went wrong
A mailbox couldn't be found for DOMAIN\user. If the problem continues, contact your helpdesk.
X-OWA-Error: Microsoft.Exchange.Clients.Owa2.Server.Core.OwaADUserNotFoundException
X-OWA-Version: 15.0.847.34
X-FEServer: MX
X-BEServer: MX
Date: 6/3/2015 10:31:41 PM
Fewer details...
 refresh the page


I can go to domain.com/ecp and see the users options and see that the user has 121MB of mail. It all started when the user seemed to become corrupt and we could no longer send mail to the account, we would get a bounce back that looked like it was trying to be sent to a different alias/all kinds of AD lingo@domain.com. I tried disabling and then connecting the mailbox back, then it wanted to use an alias that wasn't what it used to be. I clicked OK and then went in and changed the alias manually, still no go. Then I attached the mailbox to a test account and saved the mail to a PST file. Completely wiped out the Exchange and AD accounts and recreated them. Now I can login using Outlook and send/receive mail just fine. For some reason it just will not work on OWA.

Many thanks in advance!
LVL 1
Josh GarrettNerdAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
Make sure that your active directory replication is working correctly.

Repadmin /replsum
Repadmin /showrepl
Repadmin /bridgeheads

Also try and run Update-StoreMailboxState. have you tried to restart the Exchange Information Store Service?

Will.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Josh GarrettNerdAuthor Commented:
Just checked the account and it is working now without having to run anything. I originally had waited an hour for everything to update before posting this question, maybe it was just having to play catch up. In the future, would you suggest running those commands to force an AD replication? Thanks as always Will, you have been a life saver in my first try at Exchange administration.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.