VS2010 - very slow debugging

Hello
I migrated my C# - Windows Forms project.
I migrated  from VS2003 (on Windows Server 2003, x32) and .NET 1.1 to the VS2010 on .NET 4.0.
Now I run it on a Windows Server 2008 R2, x64.

Since I migrated the project, the debugging is extremly slow and almost not usable.
What could I do against this?

Regards
Eric
ICSAutomationAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Éric MoreauSenior .Net ConsultantCommented:
was intellitrace available  in VS2010? I don't remember. If so try disabling it.
0
ICSAutomationAuthor Commented:
@ Eric Moreau:
I use VS2010 professional, which has no InteliTrace (is only availible in VS2010 Ultimate)
0
GMGeniusCommented:
I had this,  was very painful when working with ASP.NET, until I found out about "Browser Link" feature and turned it off

http://www.asp.net/visual-studio/overview/2013/using-browser-link

however this is probably totally unrelated. in 2010
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

David Johnson, CD, MVPOwnerCommented:
suggest you use the latest Visual Studio Community.. This way you will be up to date. VS2015 is going to be released soon..
0
Naitik GamitSoftware DeveloperCommented:
Try to  delete all your breakpoints.
you need to click the "delete all breakpoints" button (Ctrl-Shft-F9), NOT just delete them one by one.
If Visual Studio has mangled your solution settings the latter will not work. You may need to add a breakpoint first, in order for this to work.

Hope this will solve your problem.
0
ICSAutomationAuthor Commented:
@ GMGenius:
My application is Windows.Forms, not a ASP.Net. There is no Browser Linking.

@Naitik Gamit:
I did as you suggest, but I didn't have any improvement :-(


Additional information:
The debugging in the code (with F10 / F11) is not very slow. The problem is to open a form. This takes up top 30 seconds until the form is opend.
0
GMGeniusCommented:
How about antivirus?  scanning files when access , what AV are you using?

Are the forms local or on a network drive?
0
GMGeniusCommented:
Also do you have lots of custom controls?

you could try turning this setting off

Tools -> Options -> Windows Forms Designer, set "AutoToolboxPopulate"
0
ICSAutomationAuthor Commented:
@GMGenius:
- The environement is offline and has no AV installed.
- The setting "AutoToolboxPopulate" is already turned off
- I have 5-10 custon controls on one form.
0
GMGeniusCommented:
Have you tested on another machine?
0
ICSAutomationAuthor Commented:
@GMGenius:
I tested it on a x32 bit machine. On this x32 machine the debugging is normally fast.

On my problematic x64 bit machine, I run the application in x32 mode.
What could be the influence?
0
GMGeniusCommented:
try a VS repair for starters,  It could be a vast many things unfortunately
0
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Unlikely the cause, but make sure you have not set up a Windows Symbol Server (e,g. with env var _NT_SYMBOL_PATH). This slows down non-system code debugging.
0
ICSAutomationAuthor Commented:
@Qlemo:
Thanks for advise. I do not have Symbol SErver activated.
0
ICSAutomationAuthor Commented:
Hello again

I finally found the problem.
First I deleted the *.suo (User Solution Setting) file, what didn't help.

Then I deleted the *.user (User PRoject Setting) file, and the debugging came back to normal speed!! :-)

To unterstand the reason, I checked the corrupt *.user file.
In ther I found a wrong path to a folder that does not exist any more. I guess this caused the problem. I did not investigat further.

Regards

Eric
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ICSAutomationAuthor Commented:
I found the solution myself
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.