change of public domain name on exchange 2010

I have this issue. the customer had mail.domain.tld and with a new certificate it must be webmail.domain.tld

I ran all the scripts to change the internalurl and the external url

all internal outlook clients give the popup that the name in the certificate doesn't comply with the server. outlook says it connects to mail.domain.tld but the cert of course is for webmail.domain.tld

I recreated outlook profiles to connect to webmail.domain.tld by hand, still the same popup.
recreating a profile and let all the settings come automatically goes without a problem, and on the proxy tab it says outlook has to connect to https://webmail.domain.tld

still this error keeps coming back.

I have installed numerous certs on exchange servers with public domain names and changed the settings to use that public domain name and that goes fine from internal and external.

btw.. configuring outlook client somewhere on a pc on the internet to connect to a mailbox on that server functions as it should be. it connects with webmail.domain.tld
LVL 1
Richard FrankSystems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
In order for this to work properly you need to update all of your virtual directories (internal and external) and also make sure that you configure Split DNS as well. I have wrote a HowTo for this complete process. Please see the below link.

Note that the Exchange screenshots are from Exchange 2013 however the concept is the same.
http://www.wsit.ca/how-tos/exchange-server-2/configure-split-dns-and-exchange-2013-virtual-directories/

Will.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Richard FrankSystems AdministratorAuthor Commented:
thnx, that's comprehensive.
the dns is set up ok.

after (re)running these lines returns errors
The term 'Set-MapiVirtualDirectory' is not recognized as the name of a cmdlet, function, script file, or operable progr
am. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:25
+ Set-MapiVirtualDirectory <<<<  -Identity "vandeventer-sbs\mapi (default Web Site)" -InternalURL https://webmail.vande
venteraa.nl/mapi -ExternalURL https://webmail.vandeventeraa.nl/mapi
    + CategoryInfo          : ObjectNotFound: (Set-MapiVirtualDirectory:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

A positional parameter cannot be found that accepts argument 'InternalClientAuthenticationMethod'.
    + CategoryInfo          : InvalidArgument: (:) [Set-OutlookAnywhere], ParameterBindingException
    + FullyQualifiedErrorId : PositionalParameterNotFound,Set-OutlookAnywhere


one note, this line misses a "-sign after servername
 Set-ClientAccessServer -Identity "Servername -AutoDiscoverServiceInternalUri https://mail.domain.com

maybe that's because it isn't 2013
0
Will SzymkowskiSenior Solution ArchitectCommented:
What version of Exchange are you using? The Set-MapiVirtualDirectory is only used for Exchange 2013 so you can ignore that. This is why you got that error message above.

Will.
0
Richard FrankSystems AdministratorAuthor Commented:
thnx. it's 2010 so I skipped that last line.

On exchange 2010 set-autodiscovervirtualdirectory -internailurl and -externalurl still work.
microsoft says that it is for MS internal use only but not on 2010. maybe on 2013.
[PS] C:\Users\sysadmin\Desktop>Set-AutodiscoverVirtualDirectory -Identity 'autodiscover (default Web Site)' -InternalUrl  https://webmail.vandeventeraa.nl/Autodiscover/Autodiscover.xml -ExternalUrl https://webmail.vandeventeraa.nl/Autodiscover/Autodiscover.xml

Open in new window


after I ran that command the server was completely on the new url

the last thing I had to do in outlook was to uncheck the http connection checkbox on the connection tab.

your scripts put me on the right track.

maybe you want to add on your page that
Set-AutodiscoverVirtualDirectory -Identity 'autodiscover (default Web Site)' -InternalUrl <url> -ExternalUrl <url> does work for exchange2010
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.