SBS2011 - Exchange 2010 EWS not working.

We have an SBS 2011 server which was migrated from a SBS 2008 server in 2013.

We use EWS on the SBS server to sync with SageCRM. This has been working since the migration. This week it stopped working, I found that Active Directory had a Journal Wrap error on the second DC. I have resolved this and it was still an issue so I have recreated the EWS virtual directory as per these links.
https://technet.microsoft.com/en-us/library/bb125176.aspx
https://technet.microsoft.com/en-us/library/bb124231.aspx

After recreating the virtual directory I have ran a IISreset /noforce and tested but still get the following errors below, I have used the following to test https://ewseditor.codeplex.com/ , I have also used the Microsoft Connectivity Analyzer and get the same error below.

Message: The response received from the service didn't contain valid XML.
Type: Microsoft.Exchange.WebServices.Data.ServiceRequestException
Source: Microsoft.Exchange.WebServices
Stack Trace:
   at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ReadXmlDeclaration(EwsServiceXmlReader reader)
   at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ReadSoapFault(EwsServiceXmlReader reader)
   at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ProcessWebException(WebException webException)
   at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)
   at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ValidateAndEmitRequest(IEwsHttpWebRequest& request)
   at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.Execute()
   at Microsoft.Exchange.WebServices.Data.ExchangeService.InternalConvertIds(IEnumerable`1 ids, IdFormat destinationFormat, ServiceErrorHandling errorHandling)
   at Microsoft.Exchange.WebServices.Data.ExchangeService.ConvertIds(IEnumerable`1 ids, IdFormat destinationFormat)
   at EWSEditor.Common.Extensions.ExchangeServiceExtensions.TestExchangeService(ExchangeService service) in e:\msft tools\ewseditor\EWSEditor\Common\Extensions\ExchangeServiceExtensions.cs:line 171
   at EWSEditor.Forms.ServiceDialog.BtnOK_Click(Object sender, EventArgs e) in e:\msft tools\ewseditor\EWSEditor\Forms\Dialogs\ServiceDialog.cs:line 148
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
Exception details:
Message: Root element is missing.
Type: System.Xml.XmlException
Source: System.Xml
Stack Trace:
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.XmlTextReaderImpl.Read()
   at System.Xml.XmlTextReader.Read()
   at System.Xml.XmlCharCheckingReader.Read()
   at Microsoft.Exchange.WebServices.Data.EwsXmlReader.Read()
   at Microsoft.Exchange.WebServices.Data.EwsXmlReader.Read(XmlNodeType nodeType)
   at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ReadXmlDeclaration(EwsServiceXmlReader reader)

Has anybody got any suggestions on what to do next to resolve this?

Thanks
Syntax IT ServicesService DeskAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
I might also restart the server and check again.
nashim khanExchange AdministratorCommented:
Hi,

Please get this check once and let me know.

The errors your getting indicate your not hitting the EWS endpoint eg if this was an authentication error you would be getting 401 unauthorized etc.

Check your server and firewall configuration (you might need to check your client firewall config as well)

You shouldn't need to put a port in at all unless you doing something strange with the server/firewall config.

Can you use OWA on this server ? eg does  https://81.218.142.215/owa work ? if its does try  https://81.218.142.215/ews/exchange.asmx you should also be able to browse to the WSDL file eg https://81.218.142.215/ews/services.wsdl

are you sure your pointing at the CAS Server ?



What are the patch levels like on the servers there was a know problem caused by .net 3.5 sp1 where there is hotfix to fix
 http://support.microsoft.com/kb/958934 this is an old issue from 2010 but if you aren't running the latest Exchange Service packs and rollups probably the cause.
Syntax IT ServicesService DeskAuthor Commented:
Found the problem, the bindings on the default website were incorrect, changing these fixed the issue.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Syntax IT ServicesService DeskAuthor Commented:
It worked...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.