VISUAL STUDIO VB -Crystal Reports - Data not showing in report when I drop field onto report

Just installed crystal v13 for Visual Studio 2010 - I changed the framework to 4.0.

Add a new crystal report - if i use wizard it displays crazy data that is not mine - like all the colors in one field.

If I don't use the wizard - I can place getdate on the report and it will show, but none of the fields I drop show data.
Fields are varchar(50) and ints - If I use Report Viewer - it works fine
There are no NULLS in the data. every row is filled in.

Any thoughts???
ralphp1355Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ralphp1355Author Commented:
Also,  if I try to view the data  - it is blank
mlmccCommented:
Any filtering on the report?

mlmcc
ralphp1355Author Commented:
No - it does not matter if I drop it from the table or the view i created, I see nothing.
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

mlmccCommented:
I don't use the versions for .Net and Visual Studio so I don't know how the interface works.

To see data do you have to run the app or is there a preview?
If you have to run the app does the report show just not have data?

Can you build a formula that just says something like HI or HELLO WORLD

DO the labels show?

I suspect the report runs under a system login that needs database permissions.

mlmcc
ralphp1355Author Commented:
yes there is a report preview and a data preview - both are blank
labels and like getdate() will show
ralphp1355Author Commented:
I was using a unloaded dataset - I switched to the ODBC connection and it worked.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mlmccCommented:
Glad you solved it.

mlmcc
ralphp1355Author Commented:
it worked
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.