DNS Query timeout

I'm on a home wireless network on my Laptop running Windows 8.1.  There are 2 wireless networks in the house for coverage reasons and I swap between the two fairly regularly.

The issues is my DNS queries intermittently fail. e.g. Browsing internet and get "DNS probe failed".  This is unrelated to changing wireless networks, e.g. I may not move the laptop all day and still experience the problem.

I run "ipconfig /flushdns" and it fixes the problem for a while, though I'm a bit sick of having to do it multiple times throughout the day and it usually fails when I don't want it to like when I want to post a comment here!

So I'm wondering if someone can shed some light on it or help me with the troubleshooting steps.

I have tested this and get similar issues on my tablet, ipad and phone.  I'm not sure, but I did test all day yesterday being directly connected with a network cable and can't remember getting the issue but I don't want to assume just yet that it's the wireless.

Happy to provide more info as needed.

Cheers,

Rob
LVL 43
RobOwner (Aidellio)Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Juan OcasioApplication DeveloperCommented:
Why don't you try to put both wireless on the same LAN.  Use different channels but same SSID.  This may help resolve your issue
0
RobOwner (Aidellio)Author Commented:
Thanks for responding. How would that be any different top what I've got now?

Sorry, missed that critical part that The wireless networks are on the same LAN :) just different SSIDs
0
Juan OcasioApplication DeveloperCommented:
Ok, good that's a start.  Are the channels set up differently?  If not, they you will get interference and competition.  Perhaps put one on channel 11 and the other on 6. And sorry, I thought I read you had two networks, hence 2 LANS.
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

RobOwner (Aidellio)Author Commented:
Fair assessment too *grin*. Yep I've already done a  channel analysis to make sure they're not overlapping or conflicting with any other network.
This only happens on dns requests.
0
Juan OcasioApplication DeveloperCommented:
Hmmm, just out of curiosity, if you turn off one of the wireless routers and work, does the issue occur?
0
RobOwner (Aidellio)Author Commented:
I can only suspect that it won't make a difference but I will try.  What's your thinking behind that idea?
0
RobOwner (Aidellio)Author Commented:
Yep issue still occurs with just the one router.
0
UnHeardOfCommented:
have you validated that the dns addresses you are getting from dhcp are valid and working? also check the dns addresses Co figured on your router are working. try hard coding one of your wireless devices to Google 8.8.8.8 to see if the issue goes away. just a thought.
0
RobOwner (Aidellio)Author Commented:
Already done but good suggestions :)

I try to test on another device when the issue occurs. the last time it happened (on my phone) I went to the desktop that is directly connected via cat 6 to the router and there were no issues. Stupidly I didn't test my laptop at the same time as it is on wireless...
0
UnHeardOfCommented:
are the wireless routers providing dhcp for your clients or do you have one main router for dhcp? what is the model of your wireless routers? did this issue just start or did it always happen?
0
RobOwner (Aidellio)Author Commented:
I truly believe that I have only experienced this issue on wireless. I sat all day via a direct connection and didn't experience the issue.

Are dns packets handled via a different protocol or udp etc? The wireless network is set to 802.11n only
0
RobOwner (Aidellio)Author Commented:
One Main router for dhcp.

Both devices are d-link

Router: DSL-2750B
Wifi access point: DAP-1155

This had been a problem for a while. It's just at my parents-in-law's place and I'm the only one that uses the wireless so replacing anything would be my last resort
0
UnHeardOfCommented:
dns is usually udp53. have you tried to upgrade the firmware, maybe a bug? try debugging from your windows device. in a cmd window type the following

nslookup  <enter>
set db2 <enter>
google.com
yahoo.com

when you get one that fails upload it here. maybe that will she'd some light.
0
RobOwner (Aidellio)Author Commented:
Interesting as I can access Experts-Exchange but not php.net (until i ran ipconfig /flushdns)

Capture.JPG
I ran those nslookup's for a variety of domains including php.net at the same time I had the above issue.  

I also tried to access php.net from another browser with no luck.  Works fine from my phone on the same wireless on the same network.

see if you can make any sense of it.
php.txt
ee.txt
google.txt
smh.txt
yahoo.txt
0
RobOwner (Aidellio)Author Commented:
So here's an interesting update, the router is appending a suffix ".Home" to devices on the network, however something is going screwy because when the issue occurs and I can't, for instance, access jsbin.com, just adding .Home works!?

Anyone seen this before or able to shed some light on what's happening?  This is definitely a router issue and something internal to its DNS table.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
UnHeardOfCommented:
that's what I saw in your debugging files as well. do you have the option to remove that dns suffix from your router?
0
RobOwner (Aidellio)Author Commented:
I looked for it everywhere, clicked through every setting and couldn't find it. Even exported the config (just plain text xml) and couldn't find it there so I'm guessing it's hard-coded :(
0
RobOwner (Aidellio)Author Commented:
Just interesting it only happens on devices that have connected wirelessly, not direct connected...
0
UnHeardOfCommented:
Did you check your wireless routers too¿
0
UnHeardOfCommented:
Actually anything that ends in a .com is what's appending .home. The php.net didn't append it
0
UnHeardOfCommented:
Nvm the original lookup did append it but it finally did the correct lookup without the .home. The .com completed the lookup with the .home
0
RobOwner (Aidellio)Author Commented:
But it shouldn't append it right? Why.com and not others? I can't make any sense of it but it's looking more likely like a bug with the router...

I've checked the wap but it's pretty basic and doesn't do any routing that I can see

Thanks as well, I appreciate you sticking with me on this and for the help you've given so far :)
0
RobOwner (Aidellio)Author Commented:
DNS suffix can't be removed with the current firmware
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.