TComboBox does not show focus

In a multi-form program, when a particular (subsidiary) form starts, it doesn't provide the usual indication that the TComboBox (csDropDownList) with actual control has control.
If I move focus to another control and then tab to the first control, I get the usual dotted line box inside that control.
There are a number of ON.. actions on this control, but if I add another control on the same form with no controls (and set tab order = 0) I get the same result - the new control still doesn't show that it has control.
I tried to reproduce this functionality with a simple one-form program, but it works perfectly OK.
This "feature" seems to appear in all forms in this program except the main form.
GrahamDLovellAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jimyXCommented:
Hi Graham,
I reread your post many times, but I am sorry, I can not understand what you mean, could you rephrase please:

I have difficulty understand the following:
with actual control has control
I get the usual dotted line box inside that control
There are a number of ON.. actions on this control
the new control still doesn't show that it has control

Could you add screenshot?
GrahamDLovellAuthor Commented:
Yes, it was difficult to describe, so have given you two pictures as you have suggested; one is not OK, but the other is OK.

It may be relevant that the focus works OK under some circumstances. eg. after using tab to move between fields.
ExpertExchange-FocusIssue.png
ExpertExchange-FocusIssueOK.png
jimyXCommented:
You are correct, I can reproduce.
This is related to the theme. If you disable the runtime theme this would not happen.
You should report this to EDN.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

GrahamDLovellAuthor Commented:
Thanks. I was going around in circles on this.

I can't find "runtime themes" in Project Options. It must be obvious, or I would be able to Google it.
jimyXCommented:
Which Delphi version you have there?
GrahamDLovellAuthor Commented:
XE7
jimyXCommented:
Delphi menu -> Project -> Options -> select Application.

You might need to rebuild.

PS: Disabling the theme will make your application looks like it was compiled with Delphi 7.
GrahamDLovellAuthor Commented:
Thanks.

While I prefer the theme "look", at least I now know something about what is happening, and can make an appropriate choice.
GrahamDLovellAuthor Commented:
Thanks for your clear and helpful assistance.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.