Ubuntu 15.04 connects to LAN but not internet

From my Google search, I'm not alone with this issue.  Machine automatically updated to 14.04, now it will not access the internet.  I'm not very conversant with Linux, but I have verified I can ping the following:

8.8.8.8
8.8.4.4
192.168.1.1 (default route)

But I cannot ping an address, like www.Google.com.  When I do, I get

unknown host google.com

The info under Active Network Connections looks normal.
LVL 1
Mike CaldwellConsultant to IP industryAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
In the terminal run netstat -rn to see the routing table.

Can you ping the gateway?
Do you have firewall (sfw) configured?
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mike CaldwellConsultant to IP industryAuthor Commented:
Well, runstat is not installed.  I can't install it because of no internet access!

Lots of complaints on Google about this very issue with 15.04, so I think I am just going to start over and install 14.04 from scratch, and set it to never update.  My use of this machine is very little and not very important, so I don't need to keep it current; if it works, it works.
0
Mike CaldwellConsultant to IP industryAuthor Commented:
And yes I can ping the gateway (default route).  I have no idea about the firewall or sfw; not experienced enough to know.  But really, I'm going to forget about fixing it and just go back to the earlier rev that worked fine.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

TobiasHolmCommented:
sounds like the dns isn't set correct.
0
Mike CaldwellConsultant to IP industryAuthor Commented:
TobiasHolm: OK, then how do I set the DNS correctly?  I'm a Linux rookie, so would need step by step instructions.
0
arnoldCommented:
view contents of /etc/resolv.conf
It should have one or several entries in the form:
Nameserver ip_of_name_server

Is the system use static ip or it gets IP from DHCP server?
If static, add the entry
nameserver 8.8.8.8
As it seems you want to use google's name server.
Or you can use the DNS IPs from your ISP provider.
Once the above is added, it should work.

When you run nslookup, what server/ip is reflected?
0
TobiasHolmCommented:
Open up a new question since this is already closed with points assigned.
0
Mike CaldwellConsultant to IP industryAuthor Commented:
I still see it in my open questions list.  I'll start a new one, but this one was not really completed, but fine with me if it can be close out.  The system is not offering me that option.
0
arnoldCommented:
It is closed, but it is still on your monitor list such that anytime anyone posts to it all participants are notified.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.