FTP not working

I have used FileZilla Server and now FTP Server Lite and both throwing same kind of error. Here is the description that what I have tried.

- port allowed in Router
- port allowed in my Anti-Virus and Windows Firewall
-Tried and able to connect using FileZilla FTP test site

BUT when I tried to connect using Filezilla Server, IE, Windows Explorer then no luck. At one stage I was able to get in using CMD.

Now I have taken off FileZilla Server and installed FTP Server Lite and same issue.
The error I am getting when trying to connect using port 2121, which is the default port for FTP connection then it says "ECONNREFUSED" and if I try port 21 then it says "Login Incorrect". The reason to use port 2121 because my router is saying its using port21 for something else and so its going to nominate 2121 so then configured the program for 2121
samsolutionsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

samsolutionsAuthor Commented:
I have just used the online FTP Tester website and it suceessfully logging under below settings
- Static IP Address
- username, password, port:21
- Plain FTP (insecure)

Here is the log of it
Warning: Plaintext FTP is insecure. You should use explicit FTP over TLS.
Status: Resolving address of 119.224.64.48
Status: Connecting to 119.224.64.48
Warning: The entered address does not resolve to an IPv6 address.
Status: Connected, waiting for welcome message...
Reply: 220 Welcome to Quick 'n Easy FTP Server
Command: CLNT https://ftptest.net on behalf of 119.224.64.48
Reply: 530 Please login with USER and PASS.
Command: USER done
Reply: 331 Password required for done
Command: PASS ****
Reply: 230 User successfully logged in.
Command: SYST
Reply: 215 UNIX emulated by Quick 'n Easy FTP Server.
Command: FEAT
Reply: 211-Extensions supported
Reply: SIZE
Error: FEAT response lines must begin with a single space character
0
David Johnson, CD, MVPOwnerCommented:
-Tried and able to connect using FileZilla FTP test site
I have just used the online FTP Tester website and it suceessfully loggin


it works under both scenarios so what is your problem?

in IE did you use ftp://dnsname/ or ftp://12.23.45.65 ? substitute as required
0
samsolutionsAuthor Commented:
I have tried that and it bring the Username and password. And even I supply then it just stays there.

And when I try that in Chrome it brings like Heading (Index of then in second raw Name, Size and Date Modified with emply column.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

David Johnson, CD, MVPOwnerCommented:
try something like the filezilla client .. also in your ftp server check any logs for errors
0
samsolutionsAuthor Commented:
why is it not accepting the username and password while it does accept using FTP tester website as mentioned above.
0
JohnBusiness Consultant (Owner)Commented:
Do you have Active / Passive set up correctly.  It need to be the same client and server.

http://slacksite.com/other/ftp.html
0
samsolutionsAuthor Commented:
It was setup for active mode.
Then when I gone through the FileZila Client Configuration Wizard and selected Active Wizard then it gone successfully. But when I try to connect through the main screen putting server address, username, password and port number then it keep giving the same error "ECONNREFUSED". While the settings in the background for Filezilla Client are for active mode.
0
David Johnson, CD, MVPOwnerCommented:
in your ftp server did you create a username/password and a home directory and permissions on that directory?  Try username 'anonymous' password: your email address  It does NOT use your windows user name and password unless you configure it that way.
0
samsolutionsAuthor Commented:
yes it is setup for home directory and full permissions given. and its under group. I tried with anonymous. and the user is not linked to windows user at all.
0
samsolutionsAuthor Commented:
at the end the problem was the router and it does not allow loopback from the same network. So when I tried from outside with the same setting it worked straight.

But thanks for your help
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
samsolutionsAuthor Commented:
none of the comment given here was relevant to the problem I had. And then after talking to the Router Company technician the problem was resolved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.