Problem getting new installation of Apache/Tomcat running

I've just migrated an Apache/Tomcat system that has been running for years to a new 64 bit Linux OS and Apache 2.4.6 and Tomcat 8.0.23. I've done the same on another Linux 64-bit system several months ago and no problem. Everything seems to have installed OK, but I can't access any jsp pages. I just get 404 status:
76.181.65.196 - - [07/Jun/2015:19:29:07 -0400] "GET /office/menu.html HTTP/1.1" 404 - "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko"

Open in new window

I get no errors in catalina.out. Don't even know where to start looking. My httpd-tomcat.conf is:
LoadModule    jk_module  lib64/httpd/modules/mod_jk.so

# Where to find workers.properties
# Update this path to match your conf directory location
# (put workers.properties next to httpd.conf)

JkWorkersFile /etc/httpd/workers.properties

# Where to put jk shared memory
# (Update this path to match your local state directory or logs directory)

JkShmFile     /var/log/httpd/mod_jk.shm

# Where to put jk logs
# (Update this path to match your logs directory location
# (put mod_jk.log next to access_log)

JkLogFile     /var/log/httpd/mod_jk.log

# Set the jk log level [debug/error/info]
JkLogLevel    info

# Select the timestamp log format
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "

# Send everything for context /examples to worker named worker1 (ajp13)
JkMount  /ohprs/* worker1
JkMount  /ohprs worker1

JkMount  /office/* worker1
JkMount  /office worker1

Open in new window

My worker.properties is:
worker.list=worker1

# Set properties for worker1 (ajp13)

worker.worker1.type=ajp13
worker.worker1.host=localhost
worker.worker1.port=8009

Open in new window

I can't find anything in any log files that gives me a clue. Can someone point me in the right direction? I've been flailing around looking at everything I can think of for hours!
LVL 1
jmarkfoleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jmarkfoleyAuthor Commented:
OK, I solved this one. I'll post the reason as it could be useful. To follow symlinks, Tomcat 6 used:

<Context allowLinking="true">

in context.xml. Tomcat 8 wants:

<Context>
 <Resources allowLinking="true" />

Don't know if I saw any release-notes about that!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmarkfoleyAuthor Commented:
Solve it myself
0
rrzCommented:
0
jmarkfoleyAuthor Commented:
Thanks! Didn't look there. I'll document that link for next time. Still, perhaps it would be "nicer" to generate a warning, but accept the syntax for a version. Big time waster!

I ran into another one where JkMounts are no longer inherited in the SSL <VirtualHost>. They have to be explictly defined, again. Seems like a step backward to require redundant definitions that could get out of sync. Not sure if that is documented in a "migration" page somewhere, but I spent considerable time on that one as well.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.