Deploying Dell R310 and Dell R510 Servers with MDT Problems

I have several task sequences set up to build and deploy vmware images using MDT 2012 and those work great. I also have a need to do similar deployments to physical Dell PowerEdge boxes, mostly R310, R510 and R620. All of them have idrac cards with the lifecycle controller installed.

What I have been doing is this (in a nutshell): Map the LiteTouchPE_x64.iso image to the idraq and select "attach", enter the lifcycle controller's 'deploy OS' section and configure the raid controller then allow it to connect and run the mounted ISO image. Static addresses are put into the MS wizard, the os is selected then I tell it to go.

While the OS image (usually either server 2012R2 or server 2008R2) itself ends up on the target system successfully, I am seeing errors when the MDT script tries to install .net3.5 and run "run command line" tasks. The whole thing errors out and never does updates. This exact same task sequence works great for a vmware vm but not for dell boxes.

It stands to reason that I am missing something. What am I doing wrong that the Dell boxes don't "like"? If someone has an unattended.xml and ts.xml would be handy but minus those, someone please give me a clue as to how to configure the task sequence so that it works like I expect it to such as patch updates and various settings I have put into the sequence.  Thanks in advance.
jimlock720Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
how are you trying to install the .net packages? using powershell add-windowsfeature / dism /online /enable-feature /featurename:<feature name>  adding the feature in MDT itself?
MDT Task Sequence
jimlock720Author Commented:
It is being done like this:
2015-06-07-23-54-32.jpg
It, along with vmware tools, shows up as a list at the startup boot iso. I deselect the vmware tools for a physical build. windows firewall and RDP are both successfully enabled using a powershell script.
David Johnson, CD, MVPOwnerCommented:
[Settings]
Priority=ByVMType, Default
Properties=MyCustomProperty

[Default]
OSInstall=yes

[ByVMType]
Subsection=IsVM-%ISVM%
[IsVM-True]
Applications001={0b41ce2c-03a2-49c6-a129-2f6f9e5925ea}

Open in new window

here is where you get the GUID
.net 45 is incorrect correct version below:
2nd check box not the first oneVMPlatform = Hyper-V for Microsoft Hyper-V
VMPlatform = VMware for VMware vSphere
VMPlatform = Xen for Citrix Xenserver
VMPlatform = VirtualBox for Oracle's VirtualBox
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

jimlock720Author Commented:
I uploaded the wrong screen shot. This is how .net3.5 is installed now.
2015-06-08-13-33-10.jpg
Why the info on AD structure? Is that needed to prevent the errors I am seeing?
jimlock720Author Commented:
OK guys here are the error codes I am getting:

2015-06-08-15-55-38.jpg
Any ideas?
jimlock720Author Commented:
UPDATE - I removed the task to install .NET3.5 and the entire script ran perfectly. I don't get why that one task would be hanging up the whole thing but apparently it did. I checked the log and it complained about a path to the sxs folder not found but I mapped that exact path and it works fine.
David Johnson, CD, MVPOwnerCommented:
what do you mean you mapped the path to the SXS folder.
jimlock720Author Commented:
The sxs folder on the MDT server in the MDT share has to be accessible by the running script. In this case it is located here:
E:\MDT_Deployment\Operating Systems\Windows Server 2012 SERVER STANDARD CORE x64\sources\sxs
The smsts.log log and ZTIOSRole.log both indicated an error when the script tried to install .net 3.5 (I know it's out of date but we have a requirement for it). The error was "path not found" which to me means it was looking for something in the sxs folder and wasn't able to find it.
I told the script not to bother installing .net at all and that resolved this error. I do need to find an automated way to install .net 3.x and 4.x though, preferably in the script prior to updates being applied.
jimlock720Author Commented:
So anyway, I mapped the folder as a drive on the target system (after it was up and running) and it worked just fine. That tells me that a file in that folder that is used to install .net is missing.
David Johnson, CD, MVPOwnerCommented:
try copying the xsx folder from the install media into the operating systems directory again. is this 2012 or 2012R2 ?
add a powershell script near the end or as an application forced in your customsettings.ini
netframework.ps1
----
add-windowsfeature -name net-framework-core
-----

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.