Exchange 2013 ECP gives error http error 404.0 - Not Found

I have a clean Windows 2012 build and Exchange 2013 (both evaluation copies in my VM environment). Both built cleanly but when I try to run https://<myserver>/ecp to configure Exchange users etc.  I get an http 404 error.
ClintonKAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zacharia KurianAdministrator- Data Center & NetworkCommented:
Which version of Exchange 2013 have you installed? Have you applied the latest CU?

Zac.
0
Simon Butler (Sembee)ConsultantCommented:
That is usually a bindings error in my experience.
Anything else installed on the server? If you look at the server in IIS manager, at the frontend role, does it have binding on port 443?

If you haven't installed or used CU8 for the installation, then I would update the server.

Simon.
0
ClintonKAuthor Commented:
I have just applied CU8 and rebooted but unfortunately still the same 404 error.
Nothing else installed on the server. It's a clean build AD, DNS and Exchange.
Viewing through IIS Manager, both "Default Web Site" and "Exchange Back End" have a "?" against them.
"Default Web Site" binding is 443 and "Exchange Back End" is 444
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Simon Butler (Sembee)ConsultantCommented:
The question marks against the sites are not a problem, as long as the sites are running.

On the server itself, what happens if you enter

https://localhost/ecp ?

You should get an SSL error, then the OWA login screen appears allowing you to login.

Do you have a proxy server on the network? If so, has the server been excluded from that in the browser settings?

Simon.
0
ClintonKAuthor Commented:
https://localhost/ecp gives "This page can't be displayed"
No proxy server. Just a single Windows 2012 server all on its own.
0
Simon Butler (Sembee)ConsultantCommented:
The localhost URL should always work.
If this is a test environment, I would be trashing it and redoing it, as it would appear to be a bad installation.
I work on the simple basis that Exchange should work straight out of the box - if it doesn't then it is re-done.

Simon.
0
ClintonKAuthor Commented:
I was afraid that may be the answer. Taken me ages to get this far.
Should I build Exchange straight from CU8?
0
Zacharia KurianAdministrator- Data Center & NetworkCommented:
Might be worth resetting the ECP virtual directory? and also have a look into the below MS KB.

https://support.microsoft.com/en-us/kb/2778897

Zac.
0
ClintonKAuthor Commented:
I reverted back to a VM snapshot that I took after the base build and before the Exchange install. This time round I installed using CU8 but it still ended up that I get the 404 error.
How do I reset the ecp directory?
I'll work through the kb article too
0
Simon Butler (Sembee)ConsultantCommented:
You must be doing something wrong or your initial Windows build is bad.
Exchange should work straight out of the box - so after doing the install, rebooting, you should be able to go to https://localhost/ecp (ignoring the SSL error) and be able to login.

Simon.
0
ClintonKAuthor Commented:
I'm currently going back to square one and building from scratch. I should get to the Exchange stage later this evening.
I'll take another run up at it and see how I get on.
0
ClintonKAuthor Commented:
I've done a complete rebuild from the ground up. It's a new VM with Windows 2012 Standard Evaluation and all available updates. I have installed Exchange CU8 but I still get "HTTP Error 404.0 - Not Found" when I run https://localhost/ecp
0
ClintonKAuthor Commented:
After much searching on the Internet have found the answer and that is to install the "Client Access Role" in Exchange. This seems obvious now I have discovered it but if it's the first time you've installed Exchange 2013 then it's not apparent from the install and there are certainly no clues from the error.
Thanks for the suggestions, input and help from Sembee and Zacharia.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ClintonKAuthor Commented:
Don't forget to install the Client Access Role
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.