Link to home
Start Free TrialLog in
Avatar of ClintonK
ClintonKFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Exchange 2013 ECP gives error http error 404.0 - Not Found

I have a clean Windows 2012 build and Exchange 2013 (both evaluation copies in my VM environment). Both built cleanly but when I try to run https://<myserver>/ecp to configure Exchange users etc.  I get an http 404 error.
Avatar of Zacharia Kurian
Zacharia Kurian
Flag of Kuwait image

Which version of Exchange 2013 have you installed? Have you applied the latest CU?

Zac.
That is usually a bindings error in my experience.
Anything else installed on the server? If you look at the server in IIS manager, at the frontend role, does it have binding on port 443?

If you haven't installed or used CU8 for the installation, then I would update the server.

Simon.
Avatar of ClintonK

ASKER

I have just applied CU8 and rebooted but unfortunately still the same 404 error.
Nothing else installed on the server. It's a clean build AD, DNS and Exchange.
Viewing through IIS Manager, both "Default Web Site" and "Exchange Back End" have a "?" against them.
"Default Web Site" binding is 443 and "Exchange Back End" is 444
The question marks against the sites are not a problem, as long as the sites are running.

On the server itself, what happens if you enter

https://localhost/ecp ?

You should get an SSL error, then the OWA login screen appears allowing you to login.

Do you have a proxy server on the network? If so, has the server been excluded from that in the browser settings?

Simon.
https://localhost/ecp gives "This page can't be displayed"
No proxy server. Just a single Windows 2012 server all on its own.
The localhost URL should always work.
If this is a test environment, I would be trashing it and redoing it, as it would appear to be a bad installation.
I work on the simple basis that Exchange should work straight out of the box - if it doesn't then it is re-done.

Simon.
I was afraid that may be the answer. Taken me ages to get this far.
Should I build Exchange straight from CU8?
Might be worth resetting the ECP virtual directory? and also have a look into the below MS KB.

https://support.microsoft.com/en-us/kb/2778897

Zac.
I reverted back to a VM snapshot that I took after the base build and before the Exchange install. This time round I installed using CU8 but it still ended up that I get the 404 error.
How do I reset the ecp directory?
I'll work through the kb article too
You must be doing something wrong or your initial Windows build is bad.
Exchange should work straight out of the box - so after doing the install, rebooting, you should be able to go to https://localhost/ecp (ignoring the SSL error) and be able to login.

Simon.
I'm currently going back to square one and building from scratch. I should get to the Exchange stage later this evening.
I'll take another run up at it and see how I get on.
I've done a complete rebuild from the ground up. It's a new VM with Windows 2012 Standard Evaluation and all available updates. I have installed Exchange CU8 but I still get "HTTP Error 404.0 - Not Found" when I run https://localhost/ecp
ASKER CERTIFIED SOLUTION
Avatar of ClintonK
ClintonK
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Don't forget to install the Client Access Role