ESXI 5.1

Hello,

After a major storm that knocked out power for miles, I come to notice our esxi server no longer works. I am getting the nasty purple screen of death.

With the following error.
the system has found a problem on your machine and cannot continue
Could not mount /dev: Not found

In an attempt to try to upgrade, the installer warned that it could not save my datastore and that I should move the data to another datastore. But I dont know how without an operating esxi.

Please tell me theres a fix for this. If not how can I pull the data from the machine. I realized the latest backups that I have were on one of the VMs not yet transferred off :(

Thanks
EES2020Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
Could not mount /dev: Not found
Now, hopefully I'm wrong, but this could mean that your filesystem/installation got corrupted or perhaps even mean a crashed disk or damaged parition...

So the question is, even if you were able to retrieve VM's of the datastore, will they be ok or also corrupted....

I'm guessing this is a standalone ESXi server with local storage?? How is the storage configured, RAID1/10/5/6?
0
EES2020Author Commented:
Hi spravtek

It is a RAID 10 setup. The G8 server did not report any kind of raid failure. And you are correct, this is a standalone Esxi server.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Check

1. RAID Configuration is correct with ACU.

2. Where did you install ESXi ?

on the disks ? on the array ? on a USB flash card/SD card?

3. Do you have backups of VMs ?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

EES2020Author Commented:
Hi Andrew
This is a production server that has been running fine since 2013. The RAID array is healthy. Configuration is fine.  The ESXI is installed on the array. Sadly, the backups resided in that datastore---mistake.....the sheer size and nature of the Vms made dealing with the data problematic.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Try inserting a USB flash drive or SD card into the Host, and installing it, does it give the same error about overwriting datastore.

another method, is to prepare a USB flash drive/SD card in another computer, and then plug in the USB flash  . drive or SD card, and see if you can get ESXi to boot. They check if there are valid datastores.

You have tried Recovery Mode, Shift-R at the ESXi startup?

otherwise, you will have to look at recovery route.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
EES2020Author Commented:
I mean I can see the drive that contains my VMFS volume member. It reports at /dev/sda1
So I dont understand why Esxi is reporting it cant mount /dev: not found
0
EES2020Author Commented:
Yes, I tried recovery mode, all it says is there are no other hypervisors avail. Im going to try the two methods you suggested. The second one just might work. Thanks.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
ESXi does boot ?

you can get on the console ?
0
Zephyr ICTCloud ArchitectCommented:
Yes, I'm with Andrew for the idea to boot of a USB stick with ESXi installed on it, or try to re-install ESXi via USB and see if it can find the datastore...

Could you perhaps get a screenshot of the purple screen?
0
EES2020Author Commented:
Andrew, I followed your second option. I got a new exsi booted from USB and was able to see the data perfectly. Clever on the datastore. I don't know why it didn't come to mind! The original esxi install must have been very corrupt to not want to upgrade!!! High volume office and the server is too expensive to replicate. So it ran 5.1 for 2 years.

Thanks again, you saved me 50,000 dollars or more. Must be more safe and more redundant. Lesson learned big time.
0
EES2020Author Commented:
Thanks both of your efforts for helping me. It was a highly stressful situation.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.