Server 2012 Administrator group rights on Win 7 Pro

We recently installed a new Windows Server 2012 r2 domain.

After adding a Windows 7 Professional workstation to the domain, we tried to login and make some network changes on the network settings.  The problem is when we try to access the IPv4 TCP/IP settings, the Win7 machine tells us that we need administrator privileges.  

The user account we used was part of the Domain Admin group.  We tried the Administrator group but still no success.
Currently, we must login as a local admin on the Windows 7 client to make the network changes.  I'm not sure if this is a Windows 2012 permission or a Windows 7 Pro issue with Server 2012 credentials.

Has anyone come across this and solved the problem?

Thanks,
Vince
vincetdcAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam LeinssServer SpecialistCommented:
Is the domain admin group in the local administrator group of the PC?
vincetdcAuthor Commented:
Nope.  Its not.  I'm accustomed to the Domain admin / administrators group having local admin rights on the client pc.  Is this not the case?

Just a quick note, we are currently moving our Windows 7 clients from a windows 2003 domain to a windows server 2012 R2 domain.  However, all these are "fresh" installs.  Both the server and clients are newly installed.

When we installed Server 2012 R2, there was an Administrators group which I assumed would get me administrator rights to all client machines.  When this did not work, I tried the Domain Admin group which was also not successful.

I'm not sure what I'm missing.
Adam LeinssServer SpecialistCommented:
Well, that's the issue.  If you add domain admins group to the local administrators group, that should fix the problem.  However, if someone setup a "Restricted Groups" GPO, that group will likely get wiped out until domain admins is added to the GPO:

https://social.technet.microsoft.com/Forums/windowsserver/en-US/dcff7b65-f813-4b91-8f88-6f8d19b9f924/domain-admins-group-does-not-automatically-add-to-local-administrators-group?forum=winserverDS

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vincetdcAuthor Commented:
It was not actually the solution.  Your comment did help me to look at different areas.  In the end, we did not really do anything differently.  We did not really have a solid solution or a fix.  It just kinda worked with the other PCs.  It may have been an isolated set of computers??

Thanks,
Vince
Adam LeinssServer SpecialistCommented:
If domain admins is missing from the local administrators group on the PC, domain admins won't be "admins" on those PCs.  You can try it as an experiment...compare the membership between a working PC and a non-working PC.

I know this works because we removed domain admins from the local groups on the payroll servers and now they cannot connect into those servers or do anything "admin" like on them.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.