NFS mount not showing in df

I've just upgraded to Slackware-64 14.1 and have an odd phenomenon. I have 2 NFS mounted directories on this server, /etc/fstab:
ohprsstorage:/mnt/RAID/public /mnt/public  nfs  nfsvers=3,rw    0 0
ohprsstorage:/mnt/RAID/Backups /OHPRSstorage     nfs            noauto,nfsvers=3,rw     0 0

Open in new window

When they are mounted, I can only see the one on /mnt/public when doing `df`:
> df
Filesystem                     1K-blocks       Used  Available Use% Mounted on
/dev/md0                       476460952   27938724  448021656   6% /
/dev/sdc1                      240364216  155516924   72637416  69% /mnt/Offline
tmpfs                            3923684          0    3923684   0% /dev/shm
ohprsstorage:/mnt/RAID/public 3845716480 2184943104 1656866304  57% /mnt/public
/dev/sdd1                     2930232316 1095670324 1834561992  38% /mnt/localBackup

Open in new window

Yet, it is mounted:
> ls -l /OHPRSstorage/
total 20
drwxrws--- 3 ohprso ohprs 4096 2015-05-16 02:36 Acronis/
drwxr-sr-x 3 ohprso ohprs 4096 2015-06-08 00:23 MAIL/
drwxrws--- 7 ohprso ohprs 4096 2013-05-25 15:41 SQLServerBackup/
drwxr-sr-x 3 ohprso ohprs 4096 2015-06-08 09:46 public/
drwxrws--- 2 ohprso ohprs 4096 2015-06-08 09:41 webBackup/

Open in new window

Unmounted:
> umount /OHPRSstorage/

> ls -l /OHPRSstorage/
total 0

Open in new window

This is going to be a big problem in scripts that check to see if this directory is already mounted.

Any idea why this is happening?
LVL 1
jmarkfoleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

woolmilkporcCommented:
First thing we can see is that "/OHPRSstorage" has the "noauto" option in fstab.

What do you see with "df" after

mount /OHPRSstorage

?
0
jmarkfoleyAuthor Commented:
My 1st `df` listing in the original post is after mounting. The file listing below that shows the folders on the mount. The last file listing on that posting is after unmounting -- no files.
0
jmarkfoleyAuthor Commented:
More info:  `mount` shows the /OHPRSstorage, df does not:
> mount
/dev/md0 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
/dev/sdc1 on /mnt/Offline type ext2 (ro)
tmpfs on /dev/shm type tmpfs (rw)
ohprsstorage:/mnt/RAID/public on /mnt/public type nfs (rw,nfsvers=3,addr=192.168.0.5)
/dev/sdd1 on /mnt/localBackup type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
ohprsstorage:/mnt/RAID/Backups on /OHPRSstorage type nfs (rw,nfsvers=3,addr=192.168.0.5)

> df
Filesystem                     1K-blocks       Used  Available Use% Mounted on
/dev/md0                       476460952   31052540  444907840   7% /
/dev/sdc1                      240364216  155516924   72637416  69% /mnt/Offline
tmpfs                            3923684          0    3923684   0% /dev/shm
ohprsstorage:/mnt/RAID/public 3845716480 2184964096 1656845312  57% /mnt/public
/dev/sdd1                     2930232316 1095670324 1834561992  38% /mnt/localBackup

Open in new window

0
woolmilkporcCommented:
Are you sure that "df" did actually come to an end, i.e. did not hang?

"mount" inspects the mount table, while "df" tries to look at the share itself.

If you didn't see a prompt after "df" and you had to cancel it with Ctrl-C then the NFS mount is stale, which can mean that the NFS server has some problem with that filesystem. I think we can rule out network or client problems, because the other mount from the same server apparently works.

I think an "fsck" on the NFS server against "/mnt/RAID/Backups" can't be wrong ...
0
jmarkfoleyAuthor Commented:
Found a workaround. This is apparently a known "issue" when there are more than one nfs mount: https://bugzilla.redhat.com/show_bug.cgi?id=920806. The device ID is considered "duplicate". Don't know why this needed to be "fixed" from the previous 2.6.37,6 Linux release.

Workaround is: `df -a` where -a is "include dummy file systems".
> df -a
Filesystem                      1K-blocks       Used  Available Use% Mounted on
/dev/md0                        476460952   20332696  455627684   5% /
proc                                    0          0          0    - /proc
sysfs                                   0          0          0    - /sys
/dev/sdc1                       240364216  155516924   72637416  69% /mnt/Offline
tmpfs                             3923684          0    3923684   0% /dev/shm
ohprsstorage:/mnt/RAID/public  3845716480 2184967168 1656842752  57% /mnt/public
/dev/sdd1                      2930232316 1095670324 1834561992  38% /mnt/localBackup
ohprsstorage:/mnt/RAID/Backups 3845716480 2184967168 1656842752  57% /OHPRSstorage

Open in new window

maybe when I get my slackpkg working right there will be a new update to fix this.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
woolmilkporcCommented:
As for the duplicate FS IDs:

There is an option in /etc/exports to set the FS ID "manually", like this:

ohprsstorage:/mnt/RAID/Backups /OHPRSstorage     nfs            noauto,nfsvers=3,fsid=65535,rw     0 0

65535 is just an example, you can use any 32bit number, the only restriction being that it must be unique among all exported filesystems on a given server.

I think the above could be worth a try.

Thx for the points and good luck!

wmp
0
jmarkfoleyAuthor Commented:
Figured it out, but points to woolmilkporc for helping out.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.