Ipad can't open Attachments via OWA 2013 (on premise)

So its Saturday morning and my CEO sends me an urgent request (aren't they all coming from the C level?).   He is using his Ipad Air to access our Exchange 2013 server (on Premise) via Outlook Web Access.

It seems he can't open attachments.   He receives a message that "This type of Attachment can't be accessed on this device".  Huge problem because he is a complete nontechnical person (the kind you need to ask is it plugged in?)

I can confirm that the Outlook Web Access works fine from Windows PC's, Mac, and Samsung devices... but when trying to open attachments via OWA,  it bombs.   I've tested using the following attachments;  PDF, WORD, EXCEL, PPT... and none of them open.  In fact the only thing that seems to open is Txt files.

I have checked that the Outlook Web Access Policies File Access and Web Ready Document Viewing are enabled (including Force WebReady Document Viewing when a converter is available.)   These are enabled on the Public or Shared Computer AND Private Computer or OWA for Devices.

I tried using Chrome as an alternative browser on the iPad but same message.

Using Powershell ...  the Get-OWAMailboxPolicy Default | select -ExpandProperty AllowedFileType reveals that all of attachment types in question are allowed.

Really kind of need to solve this.

Thanks for any help!
LVL 8
Jeff RodgersNetworks & Communications Systems ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeff RodgersNetworks & Communications Systems ManagerAuthor Commented:
I should add that the message he receives when trying to open/download an attachment is

"This type of attachment can't be accessed on this device"
0
Jian An LimSolutions ArchitectCommented:
are they in the blocked list ? (just a quick check)

Get-OWAMailboxPolicy Default | select -ExpandProperty BlockedFileTypes
0
Iain MacMillanIT Regional Manager - UKCommented:
Does he actually have Office for the iPad installed, so it can actually read/load the file-types?  

Do you mean using OWA via Safari, or do you mean a proper loaded Exchange ActiveSync account and profile?

I find iPads tend to prefer formats like PDF's, have you tried sending PDF, JPG and plain TXT files and see if those work.  

Has this worked in the past (perhaps before an iOS update)?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Jeff RodgersNetworks & Communications Systems ManagerAuthor Commented:
@ limjianan -  I already had checked that.   The only items listed in the blocked list are the bad stuff (i.e. executables (.vbs,.com,.bat,.exe etc)

@ IanMCMillan - He does not have the Office for the iPad installed however,  my understanding is that the WebReady Viewer would kick in and allow him to open these documents at least in a view only mechanism.    I tried on my own iPad and found that the documents still would not open despite having Word, Excel and a PDF reader on it.   This is a recent migration to Exchange 2013.    Exchange 2010 allowed all of these to open (the user was only migrated 2 weeks ago and could confirm functionality before the mailbox move).   We can't exactly move him back to Exchange 2010.

On the interim,  I have set him up with Citrix Receiver and he can access Outlook via Citrix on his iPad,  but this is not the ideal circumstance.
0
Iain MacMillanIT Regional Manager - UKCommented:
if he has the full blown ActiveSync account setup on the tablet, it would appear that 'limjianan' might be right in saying it could be a security issue with the user's mailbox and permissions for allowable file-types.  You may have fallen foul of the default Exch 13 rule during the migration from 2010.  You need to check your transport rules.

as i said what if you try to open PDF or TXT files - same open issue?

similar question here -- but don't think the Q has been answered either:

http://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/Q_28355788.html
0
Jeff RodgersNetworks & Communications Systems ManagerAuthor Commented:
Actually think I may have figured it out...

For future reference

Log into the Exchange Control Panel

Navigate to Servers -> Virtual Directories ->  OWA

Click Edit.

Navigate to the File Access Tab and Uncheck the "Force Web Ready Document Viewing when a converter is available.

Click Save.

Do a reset on the Virtual Directory.

Then started working.

I am guessing it choked on the Webready Document Viewing.

Thanks for your help.   Sometimes you just need to work thru it.  I will award some points.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Iain MacMillanIT Regional Manager - UKCommented:
glad you got it fixed....CEO's never like to be left stuck!
0
Jeff RodgersNetworks & Communications Systems ManagerAuthor Commented:
Solved my own issue but was helped by talking thru it.

Thanks !
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.