slackpkg not updating

I installed a new Slackware 14.1 from DVD, then ran

$ slackpkg update
$ slackpkg upgrade-all

The upgrade took over 12 hours. When it finished I rebooted. However, it does not look like any of the updates were installed. For example I saw that openssl 1.0.1m was downloaded, but what is still running is 1.0.1e.

How can I get the updates to install? There are some fixes I need.
LVL 1
MarkAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Duncan RoeSoftware DeveloperCommented:
man slackpkg says
Remember to use the "install-new" action before you  use  "upgrade-all".
Did you do that?
MarkAuthor Commented:
Duncan Roe:
emember to use the "install-new" action before you  use  "upgrade-all". Did you do that?
No, I didn't because, as I understand it, upgrade-all will get any new packages added since the installation. Since I'm really only needed a minimal install, I didn't really want even more new packaged.

In any case I think I've figured out what went wrong. I cleaned out everything I could find with slackpkg logs, downloads, etc. Started `slackpkg update`, which did download a bunch of stuff. Then `slackpkg ugrade-all`, but at the end of that, I still had my old programs; e.g. openssl 1.0.1e, not 1.0.1m.

So, I tried hand-upgrading. That worked for openssl and for samba (4.1.0 -> 4.1.17), but after upgrading httpd from 2.4.6 to 2.4.12 I got "httpd: symbol lookup error: httpd: undefined symbol: apr_table_getm". So did `slackpkg install apr` which did upgrade that package, but httpd then gave an undenfied symbol error with mod_proxy. I couldn't find a way to upgrade httpd modules (the install of the new httpd didn't do it), so I restored everything from before I started messing, upgraded openssl and samba and left it at that.

Later, I installed Slackware 64 4.1 on a completely different computer from the same DVD. I did the `slackpkg update` and `slackpkg upgrade-all` (it ran for about 20 hours!) and everything upgraded just fine.

What I think happened was that after installing the 1st system and before doing the upgrades, I restored production directories from the original backup (this was an update of an existing system). Those directories included /var/log and /root which hold slackpkg info. I apparently clobbered enough config stuff that slackpkg was hopelessly lost. A lesson for next time!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Duncan RoeSoftware DeveloperCommented:
Thanks
MarkAuthor Commented:
I concluded what the problem was. Points to Duncan for helping out
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.