Remote Desktop is no longer working

I have recently upgraded from SBS 2003 to a new box running Server 2012 R2 as a Hyper-V host, with several VMs running Server 2012 R2 and one running Server 2008 R2 and Exchange 2010 sp3. We still have a legacy server runnning Server 2003 R2 64-bit as a Terminal Server, but it really now has only one remote user that accesses it.
I recently turned of the old SBS box, after the migration and demoting from its DC role.
The TS is no longer accepting RDP connections. I suspect that thew two things could be related, but I am not sure how or what to do to troubleshoot it.
I had changed the RDP port and it has been working on the non-standard port for years. I have checked the port setting in the registry and it is still set correctly. I have checked the Port Forwarding settings in the router and it has not changed.
I cannot even RDP across the LAN from another workstation.
I can ping the TS across the LAN and I can connect to other servers ok.
The TS only uses the Windows Firewall and I have tried to connect with the Firewall turned off, but I still can't connect.
So, can anyone help me to get this sorted?

I plan to replace the TS box with another VM, running Server 2012 running RDS. So it might just be better to forget the TS and get the new server working. I haven't done this before so any pointers in that direction might be helpful. At this stage I basically just need to get one remote worker access to the system again, as quickly as I can.

Cheers,
Greg
gregmiller4itAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Is the user a local administrator on the server?  If not then you are going to need TS Licensing server and your SBS might have been the licensing server.  You could install the TS/Remote Desktop License Server on one of your servers and then go to Remote Desktop Host Configuration on the server in question and enter your license server.
0
gregmiller4itAuthor Commented:
I just tried to connect across the LAN as a Domain Admin and got:

"Remote Desktop can't connect to the remote computer for one of these reasons:
1)Remote access to the server is no enabled
2)The remote computer is turned off
3)The remote computer is not available on the network...."

So, it probably isn't a licencing thing.
0
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
What port is RDP configured for?  If you go to Computer Properties, Remote tab, is RDP enabled over there?  There was also an issue with some versions of Windows where a hotfix was required.  Symptoms were that if a computer affected was rebooted from an RDP connection, upon reboot, RDP connections could not be established.  Have you rebooted the server from the console and tried again?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

gregmiller4itAuthor Commented:
The port is 3390. I have previously been able to connect across the LAN using 'computername:3390'.

I'm not on-site right now but will be again this afternoon and I will check that RDP is still enabled on the server.

I did reboot the TS server this morning before I posted the question.
0
gregmiller4itAuthor Commented:
Ok, I'm back on-site and have checked that Remote Desktop is enabled on the TS. I also checked the list of names in the Remote Desktop Users group and all the required names are listed.
So, I am still no wiser as to how to fix this.
Is there a tool to interrogate RDP?
0
Tony JLead Technical ArchitectCommented:
Have you checked that it's actually listening on 3390? Do a netstat -a -o -b

Have you configured the firewall to allow connections on the new port? I know you say you've turned it off but I've seen odd behaviour in the past where this has still blocked.

Can you telnet into the port from local and/or from a machine on the LAN?

And yes...there is an RDS diagnostic tool available from MS: https://www.microsoft.com/en-us/download/details.aspx?id=40890
0
gregmiller4itAuthor Commented:
Ok, so it seems I'm in a mess here.
I disabled and re-enabled RDS and the port (as shown in the registry) has dropped back to the default port of 3389...no surprise there really.
Still can't connect across the LAN.
I checked the Windows Firewall again and the Remote Desktop exception is not ticked and not set by GP but it is greyed-out so can't be changed.
However, mstsc.exe has been added manually and is enabled.
Still, can't connect.
Disabled Windows Firewall again, still can't connect.
netstat didn't show 3389 or 3390 as a listening port.
All of a sudden, when i try to connect I get a different message:

'The remote session was disconnected because there are no Remote Desktop License Servers available to provide a license.
Please contact the server administrator'

So I googled that error which led me to look at the registry again and I found that it was looking at the old SBS server for the MS Licencing.

So, I think that rather than spend any more time trying to fix this old Server 2003 system, which is due to be decommissioned anyway, I will put the effort into getting the new Server 2012 R2 RDS server going. The RDS server is to replace the 2003 TS.

Again, this is all new ground for me, but I think I will start a new question for some pointers.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gregmiller4itAuthor Commented:
The other experts helped me to rule out some things but I finally discovered the answer (no licence server) myself via google
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.