speed up Cisco 1841 xmodem

hello experts
i have a Cisco 1841 router and the IOS is broken, i am using xmodem copy a new IOS file onto flash, but the speed is really slow, it will take 24 hours to complete, my question is there any say speed up the transfer?

thank you
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

In rommon you can set better baud speed with
set BAUD <x>
of course you need to do so on terminal program and set the same value.

And after you finish it is recommended to set values to defaults (9600).
RS-232 Serial Port standard baud rates <x> from above:

bold is preferred in my case. :)
You can use tftp or ftp to copy the IOS bin to router.
beardog1113Author Commented:
hello Predrag
please see below, does it like this? but looks like not executed.
thank you

rommon 19 > set BAUD 115200
usage: set
rommon 20 >
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Looks like that is not exists as option on 1841:

rommon 7 > confreg
change console baud rate? y/n [n]: y
enter rate: 0 = 9600, 1 = 4800, 2 = 1200, 3 = 2400 [0]: 0

But there are others options available like Recovering the System Image (tftpdnld), or usb flash.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
beardog1113Author Commented:
i have change baud rate as your instruction, i did change it to 115200, but can't connect to it once i change the rate of terminal software to 115200, any ideas?

thank you
You need to change terminal software to match speed, otherwise you get garbage in terminal software.
If you still don't connect ... try other rates.
In putty
Set speed in putty
beardog1113Author Commented:
please see below, baud already changed to 115200, i just need disconnect it, change terminal soft to 115200 then try to connect it right?

rommon 44 > confreg

           Configuration Summary
   (Virtual Configuration Register: 0x3922)
enabled are:
load rom after netboot fails
console baud: 115200
boot: image specified by the boot system commands
      or default to: cisco2-c1841

do you wish to change the configuration? y/n  [n]:  n
Yes. If registry option 0x3922 is supported by 1841.
beardog1113Author Commented:
thank you
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.