MS SQL Server 2012 - SSMS 2012 SUDDENLY NOT OPENING/WORKING

Have an installation of SQL Server 2012 Developer Edition on my development laptop (Windows 7) which has been installed for about 2 years, with several databases, and Reporting Services also installed - this installation is used daily, and was still able to connect using SSMS 2012 as recently as yesterday.

Today, after no changes to my development laptop, when I try to launch SSMS, I'm suddenly getting some unexpected error dialog boxes.

First error dialog states something like "VsDebugPresentationPackage, Version=10.0.0.0 didn't load correctly", then another error stating "Microsoft.SqlServer.Management.SqlStudio package did not load correctly", and then an error along the lines of "Failed to open connection dialog ..... Object reference not set to an instance of an object Microsoft.SqlServer.Management.SqlStudio".

I've established that I can still connect using SQLCMD, and also I can still various Reporting Services reports that run against databases on this installation of SQL Server 2012 so to all intents and purposes the actual databases and database engine are still working OK, it's just the SSMS connectivity that has stopped working, and I just can't see why.

I've tried reinstalling just the SSMS 2012 client tools, but that has not solved this error, so any suggestions on how to resolve this will be greatly appreciated (unfortunately, I haven't got my original SQL Server 2012 installation DVD onsite with me today).

Thanks

Ray
raymurphyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jerry_JusticeCommented:
Did any Windows Updates load overnight?

Try running SSMS as admin.  Does it work?
0
raymurphyAuthor Commented:
Thanks for following up, Jerry, no updates loaded and running SSMS as admins give same error ..
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
Try to install MSSQL 2012 SP2.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
raymurphyAuthor Commented:
Sorry for the delay in getting back.

Installing SQL2012 SP2 did not make any difference.

Another related problem was that VS 2010 was also giving the same 'VsDebugPresentationPackage, Version=10.0.0.0 didn't load correctly' error. After looking round various VS 2010 forums elsewhere, saw that there didn't seem to be one definitive fix for this issue, and various forums presented a multitude of possible fixes.

In the end have gone for the brute force approach and removed .Net Framework V4 , then VS 2010 then SQL 2012 from development laptop. Then reinstalled .Net Framework V4, followed by fresh installation of VS 2010 (then applied VS 2010 SP1) and then finally reinstalled SQL 2012.

After all that, everything is working OK again - not a very elegant fix, but seems to have done the trick ....
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.