AutoCAD licensing with multiple NICs

We recently purchased an iSCSI SAN for our datacenter to replace our existing iSCSI SAN.   The current SAN uses QLogic Nics to connect while the new one uses Intel x520 Nics.  

The server on which we have our AutoCAD licensing running is connected to the current SAN.  However after I installed the Intel x520 Nics  our licensing stopped working.    I disabled the x520s and our AutoCAD users starting getting licenses again.  

The New SAN is on a completely separate network from other computers/servers so I can not use the x520s for licensing.  I have rearranged the bind order of the Nics so that the connection to the corporate network is first and the connections to the iSCSI SAN are last.   The bind order does not make a difference.   If the x520s are enabled no one can get a license.   Once they are disabled the licensing starts working again.

I have a ticket open with our support but they are unsure if they or Autodesk will be able to help us. They tried to push it back on us claiming it was a networking issue not an Autodesk issue.

The server is running Windows Server 2008 R2 x64 fully patched and we are using v11.7 of the license manager.

Has anyone had a similar issue?
qvfpsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rodney BarnhardtServer AdministratorCommented:
I have not had a similar issue, but the AutoCAD license is tied to the name of the server as well as MAC address of the network card. It sounds like you need to request a new AutoCAD license if you are changing the network card. That is, if I am reading your problem correctly. You can tell which card by launching the license tool and looking at the license configuration.
0
Rodney BarnhardtServer AdministratorCommented:
Depending on your version, here is where it is located.

AutoCAD tools
0
qvfpsAuthor Commented:
I am not changing the current network connection.  I am adding a separate network card to be used exclusively to access an iSCSI SAN.

The Name of the server and the MAC address of the current card have not changed and appear as the first MAC address in LMTools.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Rodney BarnhardtServer AdministratorCommented:
I would activate the cards, the go to the License Manager, re-read the license file, and check the server status. If those seem to function and have no errors, then check the debug license. If there are no errors after these, then it can be assumed the license manager is functioning correctly. If there are errors, then it could be the OS is trying to use the license manager against the new network cards.

The other option, if this is a Windows system, would be to install Microsoft Network Monitor or another product like WireShark, then have a workstation try to obtain a license. This will allow you to see what is happening from the network perspective. I was able to solve a problem a few weeks ago by seeing how the system was responding to the client. This could narrow it down to some type of network problem.
0
qvfpsAuthor Commented:
I have tried rereading the license file and stopping and restarting the license server without making any difference.  When I look a the Ethernet address field it shows all 3 MAC addresses.  The first address is the MAC address of the network connection.  

I am going to upgrade LMTools to the latest version this weekend and if that doesnt work I will see about running a network monitor.
0
qvfpsAuthor Commented:
I was in over the weekend and upgraded LMTools to the most current version.  This did not make any difference.  

I then used Wireshark to run a capture from the PC i was using to test the licensing for both a success and a failure .   The only real difference is that the reply time for ICMP Echo (ping) request went from a range of 5-47 to a range of 1300-1500.

I used the Microsoft monitor on the server to do the same thing and there the only real difference is that I see lot of ESP protocol traffic to a corporate IIS server.
0
Rodney BarnhardtServer AdministratorCommented:
It sounds like when you make the switch, you latency is driven up. You could test this by setting the FlexLM_Timeout value. I typically have only had to do this on laptops where someone may be on a VPN, but you could try it in this case.

http://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/Error-A-valid-license-could-not-be-obtained-by-the-network-license-manager.html

Also, with the information you provided, I did come across some issues with X520 cards you are using and iSCSI performance.
https://communities.intel.com/message/175545

http://en.community.dell.com/support-forums/storage/f/3775/t/19474074
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
qvfpsAuthor Commented:
I tried turning on the AutoCAD licensing again.   This time I started a ping monitor before I enabled the network cards.   I then waited a while before I tried to start AutoCAD.   The response times for the pings never changed when I enabled or disabled the network cards.   I still could not access AutoCAD but it doesn't look like the response time is the issue.  

Sorry for the delays in replying.  This is considered a critical server and is heavily used during the day so I can only work on it after hours and If I want to bring it down for any reason I need to schedule it ahead of time.
0
qvfpsAuthor Commented:
The issue was resolved yesterday.   For whatever reason when the second nic card is activated Windows Firewall starts blocking the ports required for the AutoCAD Licensing on the current nic.   Adding rules to allow those ports resolved the issue.
0
qvfpsAuthor Commented:
Thanks for the suggestions.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
CAD/Architecture Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.