Surface Pro 3 does not automatically connect to hidden wireless networks

Surface Pro 3 on corporate domain.
Windows 8 Ent

In GPO, we added all hidden wireless networks so that our laptops will automatically connect to the hidden wireless within the office that they were in. This works flawlessly for our normal Dell laptops.

We have 5 hidden wireless networks. Each one corresponds to the Wi-Fi located at each of our 5 different locations. So if a user goes to a different office, it will connect to that offices Wi-Fi.
We have 2 broadcasting wireless networks. One is our guest Wi-Fi and one is a hotspot used by a company that rents space in our building. Staff will never need to connect to these two networks.

What is supposed to happen is as soon as a user disconnects their network cable, it will automatically connect to the hidden wireless. This works 100% for all of our laptops.

I am doing testing on one Surface Pro 3
I am unable to automatically connect to hidden wireless networks on this device. Google searches show that in order to connect to a hidden wireless network, you will have to first broadcast the network. This option is out of the question as it requires approval from multiple Engineers and our CIO whom will not start broadcasting the wireless. Its just out of the question.

To quickly summarize what is happening, after manually adding the hidden wireless, I was getting a consistent connection to the Wi-Fi after each reboot but after leaving it overnight and trying to connect again, the hidden wireless disappeared. Locking the device and letting it go to a blank screen brings the wireless back and connects… Here are the steps I have done so far and what they have produced.

Click on wireless icon in tray
The guest wireless and hotspot wireless showed
Chose the option - Hidden Network
add Our_Hidden_WIFI
Choose to add certificate. It asked me for the Wi-Fi password, not a cert..
Put in Wi-Fi password
Result - Wi-Fi connects. I reboot and Wi-Fi is gone. Wait 10 minutes. Wi-Fi never shows up. I stepped away..Computer eventually locked and that is when it connects. Tested again by rebooting and as soon as the computer logged in to the desktop, I locked the machine. The tablet connected to the Wi-Fi as soon as the screen went blank. Odd? Yes…

Moved machine to the no policies OU.
Could no longer connect to the hidden Wi-Fi when I locked the machine.

Went to Network and Sharing Center
Setup a new connection or network
Added Our_Hidden_WIFI
All setting stayed accept under Advanced setting for Our_Hidden_WIFI, i checked on Specify Authentication Mode: User or Computer Authentication (The reason I did this is because this is the setting that was checked on our Dell laptops)
Our_Hidden_WIFI connects after about 30 seconds after it boots into Windows.
Tried this twice and took 30 seconds again.
Shut down

Moved the machine back to the regular OU
Booted up. Machine connected to MEL WIFI immediately.
Rebooted. Connected immediately..

Plugged the machine back to the dock, rebooted. waited for windows to boot up. Disconnected from the dock and it immediately connected to the WIFI...

Left for the day. Came back this morning and Wi-Fi was gone again. Locked the machine and waited for the screen to turn off. Turned the tablet back on. Wi-Fi was connected!

So it seems that the only way I can get the Wi-Fi to connect is to lock the machine and wait for the screen to go black. This obviously is not an acceptable option. I have scoured the internet and cannot find any fixes or workarounds for this issue. All I can see is that it is a common issue and the solution that they want us to do is to broadcast the signal. I must stress though that our corporate size and amount of upper management team members just wont agree with what is stated on the internet.
prologic08Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Craig BeckCommented:
I would say that's a driver issue.  You may just have to wait for good ol' Microsoft to release an updated driver.
0
prologic08Author Commented:
It prob is a driver issue. I tried to find older drivers but they havent worked and this issue has been ongoing since the Surface Pro 3 came out. Nobody has found a solution yet. Its unfortunate because while I understand that hidden wireless networks are no longer a best practice, I feel like I am being forced to abide by a standard that our company is just not ready to change.
0
Jackie ManCommented:
MS just ignores it and there is no fix as it is a design flaw with the wireless card.

http://blogs.technet.com/b/surface/archive/2014/11/17/information-on-the-upcoming-updates-for-surface-pro-3.aspx#pi164708=1

Frim the above link, you can see that there is no new update for the wifi problem since its acknowledgement in Nov 2014.

The only solution is to disable the internal wifi adapter and use an external usb wifi adapter.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.