One Exchange 2007 User cannot sync mobile device

Client is running SBS 2008 and Exchange 2007 SP3. All patched and up to date.  Several iPhone / Android users on domain.

iPhone users have had occasional sync issues that were rectified by either password change or remove/re-add account on phone, or remove device partnership in Exchange or OWA interface.

One user started having sync issues with iPhone (4S, iOS 8.3). None of the usual tricks worked. I noticed that the user had 7,000 UNREAD messages in his inbox and had him pare it down (to about 800). No luck. (Mailbox went from about 15GB to abou 6GB).

The account gets added to phone successfully, but the iPhone just throws up the 'Cannot Get Mail. Connection to the Server failed' message. Samsung creates account as well but just shows his inbox folder (no subfolders) and it remains empty.

OWA works fine. Outlook works fine on PCs at office and from his laptop (in office or outside).

I tried creating a temp folder and moved a lot of mail from inbox to temp folder. No help.

I'm thinking it is something with his mailbox (not his phone), since I also cannot get his account to sync on my iPhone 4S, nor can I get it to sync on a Samsung S5. Other accounts on same domain can be added to either phone without issue.

Was thinking of changing his username to see if that helps, but if it is his mailbox, not sure how to proceed. I've read that export to PST and import to new account might cause calendar, recurring appointments, email autofill,etc. to get messed up.

Any recommendations on how to resolve?
Sal SoricePresidentAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
First thing I always do with these kinds of problems is check the partnerships.

get-mailbox username | get-activesyncdevicestatistics | select DeviceFriendlyName, DeviceType, DeviceUserAgent

If there are more than ten, then you need to remove the old ones - as too many partnerships can cause problems.

You should also be able to see the partnerships through OWA when logged in as the user.

Simon.
Sal SoricePresidentAuthor Commented:
Hi Simon,

Sorry - didn't mention that I had tried that. User only has 2 partnerships, iPhone and iPad. I've removed the phone but not the iPad. The iPad is not syncing either. Tried setting it up on my iPad as well. No luck.
Simon Butler (Sembee)ConsultantCommented:
I would remove all of the partnerships, and the accounts on the devices.
Also check that permission inheritance is enabled on the account in ADUC.
Wait at least half an hour before trying to sync again.

Simon.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Sal SoricePresidentAuthor Commented:
Tried removing partnerships. Inheritence is (and always was) on. Still can't get mail on phone. Other than that, his mailbox seems to be working properly (ie, Outlook on desktop, on laptop, Outlook Anywhere, OWA).

What's weird is that in Manage Mobile Device Manger, the iPhone (and this also happened when I tried a Samsung) just shows up under the 'type' column. The others are blank:
MobileDeviceManager
I also get a 1008 Event from Exchange (see below). As all other users are not having an issue, I'm thinking I may have to try things like changing his username, creating a new user and importing his mail from PST, etc. Any ideas on the best way to proceed?

Event ID 1008:
An exception occurred and was handled by Exchange ActiveSync. This may have been caused by an outdated or corrupted Exchange ActiveSync device partnership. This can occur if a user tries to modify the same item from multiple computers. If this is the case, Exchange ActiveSync will re-create the partnership with the device. Items will be updated at the next synchronization.

URL=/Microsoft-Server-ActiveSync/default.eas?User=johnsmith&DeviceId=ApplC38HFJTVDT9V&DeviceType=iPhone&Cmd=FolderSync
--- Exception start ---
Exception type: Microsoft.Exchange.AirSync.AirSyncPermanentException
Exception message:
Exception level: 0
HttpStatusCode: 200
AirSyncStatusCode: 6
XmlResponse:
<?xml version="1.0" encoding="utf-8" ?>
<FolderSync xmlns="FolderHierarchy:">
      <Status>6</Status>
</FolderSync>
Exception stack trace:    at Microsoft.Exchange.AirSync.FolderCommand.Execute()
   at Microsoft.Exchange.AirSync.Command.WorkerThread()
Inner exception follows...
Exception type: Microsoft.Exchange.Data.Storage.StoragePermanentException
Exception message: Could not get properties.
Exception level: 1
Exception stack trace:    at Microsoft.Exchange.Data.Storage.MapiPropertyBag.GetProperties(IList`1 propertyDefinitions)
   at Microsoft.Exchange.Data.Storage.StoreObjectPropertyBag.InternalLoad(PropertyDefinition[] properties, Boolean forceReload)
   at Microsoft.Exchange.Data.Storage.StoreObjectPropertyBag.Load(PropertyDefinition[] properties)
   at Microsoft.Exchange.Data.Storage.Folder.InternalBind[T](StoreSession storeSession, MapiPropertyBag mapiPropertyBag, StoreObjectId folderObjectId, Byte[] changeKey, PropertyDefinition[] propsToReturn)
   at Microsoft.Exchange.Data.Storage.Folder.InternalBind[T](StoreSession storeSession, StoreId folderId, PropertyDefinition[] propsToReturn)
   at Microsoft.Exchange.AirSync.FolderCommand.ComputeChangeTrackingHash(MailboxSession mbxsession, StoreObjectId folderId)
   at Microsoft.Exchange.Data.Storage.FolderHierarchySync.EnumerateServerOperations(StoreObjectId rootFolderId)
   at Microsoft.Exchange.AirSync.FolderSyncCommand.ProcessCommand(FolderRequest folderRequest, XmlDocument doc)
   at Microsoft.Exchange.AirSync.FolderCommand.Execute()
Inner exception follows...
Exception type: Microsoft.Mapi.MapiExceptionCallFailed
Exception message: MapiExceptionCallFailed: Unable to get properties on object. (hr=0x80004005, ec=-1414)
Diagnostic context:
    Lid: 18969   EcDoRpcExt2 called [length=143]
    Lid: 27161   EcDoRpcExt2 returned [ec=0x0][length=348][latency=0]
    Lid: 23226   --- ROP Parse Start ---
    Lid: 27962   ROP: ropOpenFolder [2]
    Lid: 27962   ROP: ropGetPropsSpecific [7]
    Lid: 17082   ROP Error: 0xFFFFFA7A
    Lid: 26465  
    Lid: 21921   StoreEc: 0xFFFFFA7A
    Lid: 27962   ROP: ropExtendedError [250]
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 1238    Remote Context Overflow
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x65E20102
    Lid: 23921   StoreEc: 0x3EC    
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 4999    StoreEc: 0xFFFFF9BF
    Lid: 14164   StoreEc: 0xFFFFFA1D PropTag: 0x360A000B
    Lid: 8660    StoreEc: 0x8004010F PropTag: 0x360A000B
    Lid: 4999    StoreEc: 0xFFFFF9BF
    Lid: 4999    StoreEc: 0xFFFFF9BF
    Lid: 4999    StoreEc: 0xFFFFF9BF
    Lid: 23921   StoreEc: 0x3EC    
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 13236   StoreEc: 0xFFFFFA7A
    Lid: 14997   StoreEc: 0xFFFFFA7A
    Lid: 30841   StoreEc: 0xFFFFFA7A
    Lid: 15589   StoreEc: 0xFFFFFA7A
    Lid: 11365   StoreEc: 0xFFFFFA7A
    Lid: 8485    StoreEc: 0xFFFFFA7A
    Lid: 6647    StoreEc: 0xFFFFFA7A
    Lid: 7183    StoreEc: 0xFFFFFA7A
    Lid: 7679    StoreEc: 0xFFFFFA7A
    Lid: 1750    ---- Remote Context End ----
    Lid: 26849  
    Lid: 21817   ROP Failure: 0xFFFFFA7A
    Lid: 20385  
    Lid: 28577   StoreEc: 0xFFFFFA7A
    Lid: 32001  
    Lid: 29953   StoreEc: 0xFFFFFA7A
Exception level: 2
Exception stack trace:    at Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, Object objLastErrorInfo)
   at Microsoft.Mapi.MapiProp.GetProps(PropTag[] propTagsRequested)
   at Microsoft.Exchange.Data.Storage.MapiPropertyBag.GetProperties(IList`1 propertyDefinitions)
--- Exception end ---.
Simon Butler (Sembee)ConsultantCommented:
The information you see in the partnership comes from the device - as ActiveSync is implemented by the different vendors in different ways, then it means the information sent to Exchange can differ.

The error you have pointed to is classic bad partnership. Did you remove all of them, and then wait for the domain to fully replicate the change? That also means removing the accounts from all of the devices.

New accounts are a pain, and should be avoided if possible.
The main reason being that it breaks so much. If you must create a new account, then either setup an X.500 address so the old account references still work, or simply create a new account and forward the old account to the new one. That means calendar entries, nickname entries in Outlook will continue to work.

Simon.
Sal SoricePresidentAuthor Commented:
Thanks Simon. Just to be sure I'm clear on this, would a single bad partnership affect any and all devices? As I mentioned, I could not get my or his 4S and ipads to sync, nor could I get a Samsung S5 to work either.
Simon Butler (Sembee)ConsultantCommented:
Yes, it would. A single bad partnership can stop it from working as Exchange cannot establish whether the client is allowed to connect or not. That is why you have to remove all of them, and wait for the change to replicate out.

Simon.
Sal SoricePresidentAuthor Commented:
Simon,

Unfortunately removing all (3) partnerships and his account from all devices did not work  :^(
Still getting 'connection to server failed'

Any other ideas would be welcome. Thinking of maybe changing his username to see if that would help.

I've done the X.500 entry before for a client, but I'd really hate to have to create a new account for him.
Sal SoricePresidentAuthor Commented:
Geting an ActiveSync error on the user accoutn when using the Connectivity Analyzer (which I don't get when using another user accoutn that works fine).  Looks like it may be that his mailbox is corrupt, as the FolderSync command fails. Could this mean that there is no other option thatn to create a new user and export/import his mail, calendar, etc.? Any recommendations on how best to resolve?

Thanks!

An ActiveSync session is being attempted with the server.
       Errors were encountered while testing the Exchange ActiveSync session.
       
      Additional Details
       
Elapsed Time: 828 ms.
       
      Test Steps
       
      Attempting to send the OPTIONS command to the server.
       The OPTIONS response was successfully received and is valid.
       
      Additional Details
       
HTTP Response Headers:
Allow: OPTIONS,POST
MS-Server-ActiveSync: 8.3
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5,12.0,12.1
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,Provision,ResolveRecipients,ValidateCert
Public: OPTIONS,POST
Content-Length: 0
Cache-Control: private
Date: Sun, 14 Jun 2015 18:11:32 GMT
Server: Microsoft-IIS/7.0
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Elapsed Time: 201 ms.
      Attempting the FolderSync command on the Exchange ActiveSync session.
       The test of the FolderSync command failed.
       
      Additional Details
       
Exchange ActiveSync command FolderSync failed with error code ServerError.

Response:
<FolderSync xmlns="FolderHierarchy:">
<Status>6</Status>
</FolderSync>
HTTP Response Headers:
MS-Server-ActiveSync: 8.3
X-MS-RP: 1.0,2.0,2.1,2.5,12.0,12.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5,12.0,12.1
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,Provision,ResolveRecipients,ValidateCert
Content-Length: 13
Cache-Control: private
Content-Type: application/vnd.ms-sync.wbxml
Date: Sun, 14 Jun 2015 18:11:32 GMT
Server: Microsoft-IIS/7.0
Elapsed Time: 626 ms.
Simon Butler (Sembee)ConsultantCommented:
In a lot of cases, moving the user account from one database to another will resolve issues with the mailbox.

Simon.
Sal SoricePresidentAuthor Commented:
Sorry for the delay. Move mailbox failed as well:

The wizard could not complete Click Finish to close this wizard
Elapsed time:
Failed
Move Schedule
Summary: I item(sl O succeeded, I failed
Move Mailbox
John Smith
Completion
Error was found for John Smith(iohn@somedomain.com because: Error occurred in
the step: Moving messages Failed to copy messages to the destination mailbox store
with error:
MAPI or an unspecified service provider
ID no: 00000000-0000-00000000, code: -1
Exchange Management Shell command attempted:
'pelocaWMyBusiness/Llsers/SBSLlsers/John Smith' move-mailbox -BadltemLimit '1 00'
-T argetD atabase
'SOME SERVER 01 NT hirdStorageGroupÅT hirdStorageGroupD atabase'
Elapsed Time:

I'm thinking it's time to open a case with Microsoft or just create a new mailbox.

Thoughts welcome.  :^(
Simon Butler (Sembee)ConsultantCommented:
There is a bad message or something wrong with the mailbox in question.
Unusual for a move mailbox to fail to clear it, so that suggests the problem is significant. A new mailbox, forwarding the old to the new is probably the best option.

Simon.
Sal SoricePresidentAuthor Commented:
Thanks Simon.

Not sure if it matters or is worth it (as opposed to getting Microsoft involved), but I did notice that when the account is added to the phone, you only see the top-level Inbox folder (with nothing in it). No subfolders. You can also send from the account, even though you get 'the connection to the server failed'

Not sure if its worth copying all the inbox messages to another folder, then deleting them so the inbox is empty.

Thoughts?
Simon Butler (Sembee)ConsultantCommented:
Could be a suspect message in the inbox. That would explain the behaviour you are seeing. Certainly moving the messages to a new folder and then adding them back in would be worth a try.

Simon.
Sal SoricePresidentAuthor Commented:
What ended up needing to be done (which I did with a Microsoft Engineer on a support call), was exporting everything to PST, then disabling the account and adding it back (with same email address).

Moving messages around, removing partnerships, changing password, trying to move mailbox to a new database, etc. failed. Engineer could not figure out why or what was wrong.

I did have to add an X500 address for the user so he would not get NDRs from internal users sending him mail (see LegacyExchangeDN for an explanation)

Thanks to Simon for all his help. I gave my answer some points just so readers will be guided to the summary of what actually worked.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sal SoricePresidentAuthor Commented:
Oops. Couldn't give my answer any points so I just marked it as best answer.
Sal SoricePresidentAuthor Commented:
I had to work with Microsoft to ultimately solve the problem and my comment details what actually resolved the problem.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.