VMWare Horizon - Static IP VDIs

We have an environment where some of our workstations need to have static IPs.

The best I've been able to figure out how to accomplish setting static IPs is by enabling DHCP and allowing Horizon/Composer to create the VMs. From there, I've set up a post-processing vbscript that uses the netsh command to set the static IP, gateway, and DNS servers for the PC.

However, when it does this, it loses connection to the Horizon server and says "unreachable" even though I can connect to the VDI VM and do everything I need to.

I've tried adding a line to stop and start the VMWare Horizon Agent service, but that didn't help.

Has anyone else had to to implement a static IP environment in a Horizon View infrastructure? Or have any idea how to accomplish what I need to do?

Thank you!
LVL 1
FirstcomAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dirk KotteSECommented:
would use DHCP with reservations.
0
gheistCommented:
we too
0
FirstcomAuthor Commented:
DHCP with reservations requires a MAC address, which is re-generated any time you rebuild a VM.

So an update on this. I think it' s unrelated to any network changes or static . The same issue occurs when I clear DNS entries completely and remove the script that sets the static IP. So something else is going on that is causing the agent to not communicate (or appear to be not communicating).

Any ideas?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

gheistCommented:
So what parameter is permanent when you rebuild machine? It is new machine by all detectable means.
0
FirstcomAuthor Commented:
This is unrelated to static IP. The process we're using to implement static IPs works fine - the issue is something else.
0
FirstcomAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for Firstcom's comment #a40822949

for the following reason:

Different issue.
0
gheistCommented:
You described one issue. Whats wrong with solutions?
0
FirstcomAuthor Commented:
I have no way to verify or implement the solutions described, or to determine their accuracy, since the problem wound up unrelated to the original question posted.
0
gheistCommented:
can you describe real problem in one sentence?
0
FirstcomAuthor Commented:
I just finished up a call with VMWare Support on this issue.

The issue with the agents not connecting to the client server is still unknown. However, we have resolved it.  I had to go onto the View Connect server and run the vdmadmin command in a DOS console for the desktop pool/VM impacted. That reset an internal key in Horizon and fixed the issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gheistCommented:
Which I expected to hear, thanks and have fun
0
FirstcomAuthor Commented:
Resolved on our own.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.