Backup Exec 2012 will not delete expired media sets

We are currently backing up to 2 NAS Drives in a weekly cycle: settings as follows

2 NAS drives in a Device pool

NAS1 Monday is a full back with the rest of the week as incremental backups. - 14 Days retention
NAS2 Monday is a full back with the rest of the week as incremental backups  - 14 Days retention
 
When the device is becoming full, backup exec will not delete the old backup sets even though it can see it as expired. I have been on the phone with Symantec support number of times and they seem none the wiser. I've followed the articles below

http://www.symantec.com/connect/articles/automated-disk-management-and-data-retention-backup-exec-dlm-or-data-lifecycle-management


Any other ideas?

Deepin
LVL 6
DeepinInfrastructure Engineer Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Thomas RushCommented:
Is it necessary for the jobs to be actually deleted?

I would expect a backup application to keep backed up data past the retention date, so long as the application was under its quota.  i.e., if you have allocated BE 2TB of space, then why not let it keep even expired data, until that space was needed for a newer backup job?    Once marked 'expired', that space can be reclaimed at any time it's needed.  But once the data is deleted, it's gone.  I can imagine without much effort several scenarios where I would have expired data on a tape (or disk) and realize I (unexpectedly) needed to recover a file from that data store.
ktaczalaCommented:
Do you have both NAS devices online all the time or do you swap them out?  If a backup set expires and it cannot find the file on the NAS it will not delete it NOR will it delete it once you bring the other device online.  If that's the case, right click on the backup set and click expire again.  Wost case is you have to manually delete the backup sets from the NAS Devices.
DeepinInfrastructure Engineer Author Commented:
SelfGovern - when the drive is full, Backup will not delete the expired data. I cant keep checking the drive to make sure there is enough space on the drive. backups are failing because they they don't get checked.



ktaczala - fortnight rotation. once the drives are plugged in the sets are marked as expired but wont clear themselves . That's what I'm trying to fix, I cant keep checking the drives to ensure there's enough space left.

I work for a MSP so automating this would help greatly.
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

ktaczalaCommented:
Here's an article discussing the issues others are having.  According to this article it won't delete until space needed.
This is for 2014 but they discuss how 2012 worked.
http://www.symantec.com/connect/ideas/backup-exec-2014-deletes-expired-backup-sets-space-available
ktaczalaCommented:
Another interesting article on how 2012 DLM works.
https://support.symantec.com/en_US/article.TECH187957.html
DeepinInfrastructure Engineer Author Commented:
Ktaczala - same as the article i post .Thanks
Tony GiangrecoCommented:
Connect the Nas device to the network, open backup Exec and go to the Storage tab showing that device. make sure its online and accessible.

Right Click the Nas and select inventory and cataloge Now. It will run a job that will check the datasets, expire old ones and update the listing of current datasets on that drive.

Hope this helps!
Tony GiangrecoCommented:
Another option we perform is to open Drive Management on the server or drive Management on the specific Nas interface and perform a format or manual delete of the drive to delete all datasets. then in Backup Exec, right click that storage device and select Inventory and Cataloge. This resolves the issue quicker.  be very careful you select the appropriate NAS device.

We perform this function monthly with Backup Exec and it works very well.
DeepinInfrastructure Engineer Author Commented:
Symantec recommended to upgrade backup exec to V15 - which has worked. Once it was upgraded i could see my existing media sets deleting themselves and the space on the hard drive was reclaimed

thank you for everyone your help

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DeepinInfrastructure Engineer Author Commented:
Solutions/articles provided by other members did not help
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.