Cannot move public folder replicas

We have an Exchange 2003/2010 environment and I've been trying to move the public folder replicas from 2003 to 2010 so that I can uninstall 2003 but I'm having very little luck.

I've turned up diagnostic logging and see no issues.  I've tried moving all replicas on the 2003 server and MoveAllReplicas.ps1 on the 2010 server.  I've tried this half a dozen times and waited days but no luck.  SMTP is working and I've tested sending mail between mailboxes on both servers.  I've scoured Google and ran through various scenarios but none of them work.

Is there a way to manually remove the replicas using ADSIEDIT or perhaps I'm missing one key step in the process.
markbeasAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
If you have any special character in your public folder name. Then it will not move. You need to remove any special character, whitespace from your Public folder name and then start the replication.
0
markbeasAuthor Commented:
No special characters are in the folder name.  The system public folders won't move either.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

markbeasAuthor Commented:
Event ID 3017s (type 0x20) are recorded on a regular basis.  Replication appears to be working fine - just can't move the replicas.
0
AmitIT ArchitectCommented:
Do you see data on Exchange 2010 PF database?
0
markbeasAuthor Commented:
Capture.jpg
0
AmitIT ArchitectCommented:
0
markbeasAuthor Commented:
Ran through step 1 and checked my application log on the 2010 server.  Here is what I'm seeing:

Capture.jpg
0
AmitIT ArchitectCommented:
Wait for some time and check again later. If you see same error.
0
markbeasAuthor Commented:
Just checked logs and there are no replication errors.  I ran the MoveAllReplicas.ps1 script and will report back.
0
markbeasAuthor Commented:
After running the MoveAllReplicas.ps1 script, I get a ton of 3093 replication errors, over 100!
0
AmitIT ArchitectCommented:
Wait and leave it for sometime. For me it took 6 months to move all PF to 2010.
0
markbeasAuthor Commented:
Nothing is moving.  I tried this exercise about a month ago and still nothing.  The public folders are all but empty. I have a hard time believing it would take over a month to move empty folders, especially when other migrations that I have done (over half a dozen) take less than a day.  I think something else is going on.
0
DeepinInfrastructure Engineer Commented:
I've used this guide a few times and it's worked for me no problems covers all areas start to finish

http://www.petenetlive.com/KB/Article/0000426.htm
0
AmitIT ArchitectCommented:
Did you created bidirectional connector between 2003 and 2010?
0
markbeasAuthor Commented:
Deepin:  I have gone through the link you provided already.  One item to note... we had an issue where the discovery mailbox was orphaned due to a corrupted database that was removed on the 2010 server.  We have since removed and recreated the system (arbitration) mailboxes.  I have not run through this link since then so I'll give it a try today.

Amit:  Yes, I removed the old connectors and rebuilt the bidirectional connector between the two servers.  Mailflow works both ways.
0
AmitIT ArchitectCommented:
Okay, create one new PF on 2003 and then add replica for 2010 and let me know if that replicates or not.
0
markbeasAuthor Commented:
I added a PF called test Test and it has not replicated.  Still seeing a ton of event id 3093s on the 2010 server.

Error -2147221233 reading property 0x67480014 on object type tbtReplication from database "Public Folder Database 0781289136".

I also noticed after running through Deepin's link that I cannot click Manage Settings on some of the folders in 2003, including the new Test folder that built.  This has been an issue all along.

Capture1.PNG
Capture2.PNG
0
AmitIT ArchitectCommented:
0
markbeasAuthor Commented:
Yes, replication is enabled.
0
markbeasAuthor Commented:
OK, found another issue with the server.  I inherited this "migration not completed" scenario so please bare with me.

Looks like mailflow both externally and between 2003 and 2010 is NOT working.  Checked the queues on 2003 and there are 1,120 queued messages on the 2010-2003 routing group connector.
0
AmitIT ArchitectCommented:
Looks like you have some permission issue or firewall issue. which is blocking the communication between 2003 and 2010.
0
markbeasAuthor Commented:
I can telnet to port 25 on the 2010 hub transport server from 2003 just fine.
0
AmitIT ArchitectCommented:
Can you send email via telnet?
0
markbeasAuthor Commented:
I can send email internally, but not externally - Unable to relay.  Tried rebuilding the connectors and messages are still queued.
0
AmitIT ArchitectCommented:
I think you know the cause now, you just need to fix it. After fixing, your PF issue should be also resolve.
0
markbeasAuthor Commented:
Still no luck.  I fixed the relay issue for Exchange 2003 and that works using telnet.  However, I still cannot send internal and external emails from OWA.  There are still 1140 queued messages in the routing group connector queue.  I tried removing the SMTP connector since outbound mail goes out of 2010, but no change.
0
AmitIT ArchitectCommented:
Did you disabled firewall on 2010? If not run this command.
netsh advfirewall set allprofiles state off

You need to run it in admin mode.
0
markbeasAuthor Commented:
Firewall is disabled through GPO and there is no AV on the 2010 server.
0
AmitIT ArchitectCommented:
I might suggest you to open case with MS.
0
szichenCommented:
Hi Mark,

Have you tried creating an "SMTP" connector (not RGC) in exch 2003 & forward all emails to exch 2010? Exchange 2010 IP should be the IP for the smarthost?

Also check (on Exch 2003 server>>Exchange Manager) that Integrated Windows Authentication is checked under Protocols>>SMTP>>Default SMTP Virtual Server under Properties>> Access >>Authentication
0
markbeasAuthor Commented:
Problem solved!  The default SMTP port was set to 125 instead of 25.  Once I changed it back, mail started flowing and I was able to move all of the public folder replicas.  Discovered that setting by running the Exchange BPA.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
markbeasAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for markbeas's comment #a40825447

for the following reason:

I found a clue to the solution by searching Google while waiting for suggestions to come in.  After running the Exchange BPA and digging in the results I found that the default SMTP port was not set to the default port of 25.
0
AmitIT ArchitectCommented:
You mention you are able to telnet. I assume I guided you right path to fix this issue.
0
markbeasAuthor Commented:
I fixed the relay issue that I found by telneting to port 25, but this did not resolve the issue.  The Best Practice Analyzer was never mentioned in this thread and that is what ultimately revealed the issue.
0
AmitIT ArchitectCommented:
How it is possible you are able to send email using 125 earlier. Difficult for me to understand.
0
markbeasAuthor Commented:
The server was never able to send mail, hence the queues filling up.  Replication emails were stuck in the queues and replication was not working.  As I mentioned, I inherited this mess and apparently someone along the way changed this setting for some unexplained reason.  Finishing up uninstalling Exchange 2003 and decommissioning the server.
0
AmitIT ArchitectCommented:
In your post number 40824736 you mentioned.

I can telnet to port 25 on the 2010 hub transport server from 2003 just fine.
0
markbeasAuthor Commented:
Ah, maybe I see where the confusion lies.  The TCP port was set to 125 on the Default SMTP Virtual Server on the 2003 server, not the 2010 hub.  Default SMTP Virtual Server (properties) -> Delivery -> Outbound connections
0
AmitIT ArchitectCommented:
Yep, that was the confusion at my end.
0
markbeasAuthor Commented:
The default SMTP port on the SMTP Virtual Server was set to 125 instead of 25.  Once I changed it back, mail started flowing from 2003 to 2010 and I was able to move all of the public folder replicas.  Discovered that setting by running the Exchange BPA.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.