Enter key doesn't work with Google on Firefox

I've been frustrated for a long time by the fact that when using www.google.com to search, when entering search terms I get a new screen with my search terms at the top and the text, "Press Enter to search." but pressing enter is ignored.  Clicking the blue search button works.  Well I finaly had enough and tried searching this problem.  There are tons of comments from 2009 but this is 2015 and the versions of Firefox and other possible software conflicts mentyoned have changed so much, I haven't gotten anywhere with this.  If I turn off instant predictions, I stay on the main screen when typing but enter still does not initiate a search.

I have Firefox 38.0.1, some plugins and add-ons, Avast AV and not sure what else to mention.

IE 11 works fine but I try not to use that.
BCSSupportAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jcimarronCommented:
BCSSupport --
Is this something recent?  If so run a System Restore to a time before the problem started.

Have you rebooted the PC recently?

Uninstall/Reinstall FF

I understand the Enter key works OK in IE.
0
David Johnson, CD, MVPOwnerCommented:
Guessing that one of your add-ons is the problem.. as I can't reproduce your problem the enter key works fine here
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BCSSupportAuthor Commented:
Is there a way to restart Firefox in safe mode without addons?  I though there was in a start menu group but I only see a single icon for Firefox, none with any safe mode options.
0
BCSSupportAuthor Commented:
I found Firefox safe mode.  I have dozens of tabs open right now so I'll try it out soon.  Yes, this has been going on for some time, months maybe.  I usually restart the PC about weekly.
0
BCSSupportAuthor Commented:
I'm not sure if this was an extension or plug-in or what but I removed a bunch of them that I didn't recognize and the problem went away, thanks for the tip!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.