Cannot import in Photo Gallery

When I scan a photo in MS Photo Gallery (Import), the saving of the picture fails, saying: The specified path is invalid.

This is regardless what I set as path in Options-Import.
Any help would be appreciated.
TheoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobusCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TheoAuthor Commented:
Thanks. I just ran SFC. It found errors but couldnt repair them all and referred therefor to the cbs.log. But when I go there is get 'access denied'
TheoAuthor Commented:
Oh and the original problem is still there.
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

TheoAuthor Commented:
Just opened the log file - as administrator
TheoAuthor Commented:
A typical message from the log (there are several json related messages, they are all very similar, have not been able to check differences):
2015-06-10 09:27:30, Info                  CSI    00000515 [SR] Cannot repair member file [l:66{33}]"telemetry.ASM-WindowsDefault.json" of Microsoft-Windows-Unified-Telemetry-Client, Version = 6.1.7601.18839, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
nobusCommented:
in some cases, running sfc a second time helps
in any case - that message points to OS corruption - so ;look in event viewer for errors
the oldest ones can point you to the cause
TheoAuthor Commented:
I have ran SFC now three times.
Event log showed errors with Bonjour service and NVStream service. Disabled both, restarted, tried again, but in vain. Problem still there.

When I use another program (PaperPort) to scan it works without a problem.
TheoAuthor Commented:
This computer was once part of a domain, but was disjoined from it. Software is still the same. It might be that the registry still contains something pointing to that domain. However I reinstalled PhotGallery today as well and it made no difference.
TheoAuthor Commented:
Since my SFC log mentioned upload problems and error nr I found a MS Fix here: https://support.microsoft.com/en-us/kb/2530477 . Useless though.
nobusCommented:
i suppose you can also scan without problems then from Paint>File>import from scanner ?
TheoAuthor Commented:
Hadnt thought of it yet, but indeed, I can.
TheoAuthor Commented:
Solved! And it was indeed a remnant from the old domain that I mentioned. On this page was the main hint: http://answers.microsoft.com/en-us/windows/forum/windows_7-pictures/how-to-change-import-settings-when-importing/973a11cf-deba-4861-b35d-66568e88b4ab 

When I went to the registry key mentioned I noticed the references to my old domain, changed them to existing paths, and that was it.
nobusCommented:
dood to hear you've solved it

if no more help is needed, plse close this
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Photos / Graphics Software

From novice to tech pro — start learning today.