ACT! 2013 Premium error post SQL move.

I've recently moved an ACT SQL database from a Windows 2008 r2 server (same SQL version) to a Windows 2012 server with SQL 2012, the database restored fine but Act now when opening the (edited) .PAD file returns to the previous screen without any message.

If we try to open the .adf file directly the error "Failed to open a connection to the database"

The event viewer shows an error:

Log Name:      Application
Source:        MSSQL$ACT7
Date:          10/06/2015 09:42:17
Event ID:      18456
Task Category: Logon
Level:         Information
Keywords:      Classic,Audit Failure
User:          N/A
Computer:     ACT-SERVER
Description:
Login failed for user 'ACTACCESS'. Reason: An attempt to login using SQL authentication failed. Server is configured for Windows authentication only. [CLIENT: <local machine>]

 SQL has mixed authentication enabled and active. Also port 1434 has been opened on the server but I cannot telnet to it as suggested elsewhere online.

Any ideas, anyone?
LVL 1
riverbankAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vitor MontalvãoMSSQL Senior EngineerCommented:
Did you update the connection to the new SQL Server instance?
riverbankAuthor Commented:
Yes, we've done that.
Vitor MontalvãoMSSQL Senior EngineerCommented:
Weird. By the error message it looks like it only accepts windows logins but you said that you confirmed has mixed authentication enabled.

Default port should be 1433 but you can see in the Configuration Manager which port is really being used. Check if is set to dynamic or static port.

Also check if SQL Browser service is running.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

riverbankAuthor Commented:
Thank you for your suggestion.

SQL Browser service is running.

There wasn't a static port, which has now been applied as 1433 as suggested. Restarted SQL services. unfortunately still the same error and behaviour.

I've added a firewall rule for 1433 in and outbound. Although testing seems to show that there is some sort of firewall problem. I've turned the firewall off for testing and cannot telnet to 1433. So far I've managed to connect on port 80, but that's all.
Vitor MontalvãoMSSQL Senior EngineerCommented:
Strange. Are you talking about a firewall as hardware or the Windows Firewall? Just want to be sure that Windows Firewall is turned off.
riverbankAuthor Commented:
Windows firewall, yes, it is strange!
Vitor MontalvãoMSSQL Senior EngineerCommented:
Check in the Configuration Manager if TCP/IP protocol is enabled for SQL Server.
riverbankAuthor Commented:
It is.
Vitor MontalvãoMSSQL Senior EngineerCommented:
Did you check again the Event Viewer? May be the error different this time?
riverbankAuthor Commented:
Unfortunately not, it's still the same.
Vitor MontalvãoMSSQL Senior EngineerCommented:
Ok. We already saw everything in the SQL Server side. How about the application side?
How it is configured to access the database? There's any Windows Authentication option checked? Or the user name and password as corrected introduced?
riverbankAuthor Commented:
We've only got the option to open it from the pad or adf files, so there's no config to amend in the app itself (sadly!).
Vitor MontalvãoMSSQL Senior EngineerCommented:
So you can't get the information yourself then. Can you get if from anyone else? If the application is misconfigured then it should be solved.
riverbankAuthor Commented:
There isn't any config to do. The app opens, then you choose an ADF or PAD file, there are no options to open or amend settings.
Vitor MontalvãoMSSQL Senior EngineerCommented:
Ok. I didn't know how the application works. So, where did you change the server name to point to the new one?
Also, 'ACTACCESS' login is created and have the proper permissions in the database, right?
riverbankAuthor Commented:
Yes, we've changed it in the PAD file, you can also point it to the ADF file which should create a new PAD file.

We've added the all the ACT SQL users needed in SQL management studio.
Vitor MontalvãoMSSQL Senior EngineerCommented:
I'm running out of ideas. The only suggestion I can make now is to recommend you to double or triple check everything. Should be something minimal but you still need to find it.
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Pretty sure you'd need to upgrade Act! to v17.1 to have a chance of it working with the later version of SQL

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ACT

From novice to tech pro — start learning today.