SQL SERVER 2008 linked server openquery ORACLE error

Hi,
i am in the process of moving some tables from a SQL 2005 environment to SQL2008r2 and have encountered an issue with an Oracle linked server. When I execute the following openquery
SELECT     a,b,date1,date2
FROM         OPENQUERY(REVENUEDM, 'select * from ORACLEDB.client_test')  
OLE DB provider "OraOLEDB.Oracle" for linked server "REVENUEDM" returned message "ORA-01858: a non-numeric character was found where a numeric was expected".
My question is I suspect this is an issue with the ORACLE driver for SQL Server but is there any way around this and how is it possible to find the offending data as no matter what I tried in the query I was getting the same error.
Any assistance would help.
Thanks.
twfw123Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
IIRC I got this error with 64bit Oracle OLE DB drivers (only), and was not successful with setting NLS parameters. The issue is caused by decimal and thousands separator (as I've seen from traces), and I could not do anything against it. I'm anxious to see any Expert having some hints ...
EugeneZ ZhitomirskySQL SERVER EXPERTCommented:
try to identify "problematic" Oracle  columns of the client_test table:

and see if you can use , for example- to_date function to specify the format for dates passed as strings

see more
Every Bug is a Microsoft bug until proven otherwise
http://blogs.msdn.com/b/dataaccesstechnologies/archive/2012/01/20/every-bug-is-a-microsoft-bug-until-proven-otherwise.aspx
twfw123Author Commented:
Is it possible to install the 32 bit Oracle Driver to counter this issue or any other method that anyone knows  - or is this a cross compatibility issue that will not be not possible to fix? Im really hoping it’s the first…
Thanks
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
My workaround is to use 32bit MSSQL with 32bit Oracle drivers.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.