takes time opening mapped drive


I have a Windows 7 pc connected to a Windows 12 Server. The pc takes a long time opening a mapped drive. If I make a shortcut with the unc path, it opens instantly. How can I make the mapped drive open with the same speed?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lionel MMSmall Business IT ConsultantCommented:
When you click on the mapped drive or any drive Windows explorer is actually reading the data on the drive to see what is there (note the status bar on top). If there is nothing in the mapped drive it will open almost immediately, if there are lost of files and folders it will take longer and since you can't add mapped drives to an index I don't know of any way to make this go faster, other than a faster PC. I have the same issue with a 4TB external drive that I do not have indexed; whenever I turn it on switch to its local drive it takes a long time to become "available".
Delphineous SilverwingGood Ol' GeekCommented:
From a command prompt (as administrator), check if Auto-Tuning is enabled:
netsh interface tcp show global
About the middle will be "Receive Window Auto-Tuning Level" - does it show "normal"

Try disabling the tuning:
netsh interface tcp show global autotuninglevel=disabled

To re-enable use:
netsh interface tcp show global autotuninglevel=normal

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zelfanetAuthor Commented:
Command was slightly different but worked!!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.