unable to find users in the GAL, and manually download the GAL

Hi MS team,


We recently had to build all the CAS servers from scratch due to a maintenance to repair catalog index failed on the exchange 2013 environment.

With this change, some users are unable to lookup users from the GAL. When you try to manually download the GAL, you can see following error:

Task 'xxxxxx@domain.com' reported error (0x8004010F) : 'The operation failed. An object cannot be found.'


Exchange environment:

2013 CU8 all the servers

Windows 2012 R2 OS for all the VMs

5 mailbox servers in a DAG

4 CAS servers behind a F5 HLB

2 Edge servers per site

Any ideas on how to resolve this issue?
Jerry SeinfieldAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amit KumarCommented:
Please follow below link, also check when user is on internet without using any proxy.
0
Jerry SeinfieldAuthor Commented:
sorry, forgot to mention that everybody is experiencing this issue
0
Amit KumarCommented:
Sorry forgot to paste article link..

https://support.microsoft.com/en-us/kb/939765 

As per this article if outlook is using proxy server, so localname bypass is mandatory. But to isolate this issue connect a machine direct to open internet and remove all proxy settings. Also check user must be outlook anywhere enabled then check GAL is downloaded or not.

One more thing try to browse https://mailURL/oab. it should show 403.4 forbidden page in browser.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Jerry SeinfieldAuthor Commented:
Hi Amit,

Everyone is running into the same issue now. This happened just after we had to rebuilt from scratch all CAS servers/

Please, see attached screenshots, and link below, let me know your thoughts
http://msexchangeguru.com/2013/12/04/e2013-oab/
OAB1.jpg
OAB2.jpg
OAB3.jpg
OAB4.jpg
0
Jerry SeinfieldAuthor Commented:
To clarify, all users are experiencing same issue
0
Amit KumarCommented:
Check DBs which OAB is assigned, also check mailbox server which is generating OAB and see if required CAS Servers are added with both methods. Then check browsing \\MailboxServerName\ there will be a share of Exchange OAB which will have a directory. Once it is there then check if same directory is available on respective CAS servers in Exchange installation folder in OAB folder, see modified date as well on both MBX and CAS those must be updated. You can instantly update OAB on CAS server by restarting MS Exchange File Distribution service.
0
Jerry SeinfieldAuthor Commented:
From EAC


The global address list show the following information


(Alias -ne $null -and (ObjectClass -eq 'user' -or ObjectClass -eq 'contact' -or ObjectClass -eq 'msExchSystemMailbox' -or ObjectClass -eq 'msExchDynamicDistributionList' -or ObjectClass -eq 'group' -or ObjectClass -eq 'publicFolder'))


Should I create a new global address list?


if so, please send instructions based on all screenshots attached


https://technet.microsoft.com/en-us/library/bb232068(v=exchg.150).aspx


https://technet.microsoft.com/en-us/library/bb123785%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396


https://technet.microsoft.com/en-us/library/bb232119(v=exchg.150).aspx


http://blogs.technet.com/b/exchange/archive/2013/01/14/managing-oab-in-exchange-server-2013.aspx
0
Amit KumarCommented:
refer below article and update OAB then immediately monitor Application event logs on OAB generation mailbox server if you see any error while updating offline address. There will be success logs too.

https://technet.microsoft.com/en-us/library/aa997684(v=exchg.150).aspx 

Don't delete anything it can mess your environment, you can create another OAB

This article will help you to identify OAB generation server ---- http://blogs.technet.com/b/exchange/archive/2012/10/26/oab-in-exchange-server-2013.aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.