Hyper-v : Cant ping physical network after creating Virtual switch

I have a server with 4 nics running Server 2012 R2. I have created a nic team containing all 4 adaptors.

I have then installed Hyper-V server. It has 2 Server 2012 R2 servers on it as VMs.

I have created a virtual switch using the teamed nic mentioned above.
I have ticked the box to share the virtual adapter with the management OS.

The host server has an ip address of 192.168.100.1.
The VM servers have ip address of 192.168.100.10 and 11 respectively.

My problem is that I cant seem to connect the VMs to the physical network. I cant ping 192.168.100.10 or 11 from 192.168.100.1 or vice versa. I also cant ping the router from the VMs.

What am I doing wrong?
LVL 1
roy_battyDirectorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
One NIC with four ports or two NICs with two ports?

Create one team of two ports (one per adapter if two NICs) for the host OS to communicate with the production network.

Create another team of two ports exclusive to the vSwitch.

If Gigabit connections and Broadcom NICs make sure VMQ is disabled for _all_ physical ports on the server.

You will need to remove the vSwitch already created from the VM(s) before deleting it and the underlying four port team.

EDIT: Check out my Hyper-V Hardware and Software Best Practices EE Article for some additional insights.
roy_battyDirectorAuthor Commented:
I deleted all the NICs from the team and then recreated the team. Everything then started working as it should.

Not sure why it didnt work before but it works now.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
roy_battyDirectorAuthor Commented:
Thanks for the advice here.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.