IIS 8.5 401 Errror Please help

Windows 2012 R2 64 Bit server
IIS 8.5

Been working on my web site for the past few day troubleshooting the site pages.

Using Microsoft Expression Web 4 with WebDAV

I was having a problem with WebDAV so I enabled Windows Authentication on the site

It was brought to my attention that now some of the pages on the site give a

401 - Unauthorized: Access is denied due to invalid credentials.
You do not have permission to view this directory or page using the credentials that you supplied.

Not all the pages which is very puzzling to me.

So this morning I disabled Windows Authentication and the only Authentication I have enabled is Anonymous Authentication

After I changed this back I did an iisreset /noforce.

But I am still getting the 401

Also the WebDAV is not working

When I try to publish I get this

The web server does not appear to have any authentication methods enabled. It asked for user authentication but did not send www-authenticate header.


I have two other sites under this IIS 8.5 all using port 80  and they are working with no issues


What am I missing here.


Thanks in advance

Tom
LVL 23
Thomas GrassiSystems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Paul MacDonaldDirector, Information SystemsCommented:
There are obviously some authentication issues here.  The easiest thing would probably be to delete the folder with the site from the web server, create a new folder, publish the site to the new folder, then tell IIS to look for the site in the new folder.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thomas GrassiSystems AdministratorAuthor Commented:
Yes an authentication problem
Why would some pages work and not others on the same site?

All my research was for older versions of IIS and no where did I read deleting the folder would clear this up.

Any other thoughts
0
Paul MacDonaldDirector, Information SystemsCommented:
Okay, don't delete the old site.  Just create a new folder, publish to that new folder, then point IIS to that folder for the site.  You'll effectively have no down time and you should be back where you started and can proceed from there.

Going back and trying to figure out what you've done to the extant site and its permissions on the file system would be difficult if I were actually there.  Doing it over EE would be impossible.  Starting over seems like the best approach to me, but I won't try to sell you on it.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

Thomas GrassiSystems AdministratorAuthor Commented:
If I blow away the folder can I recreate with the same folder name?
0
Paul MacDonaldDirector, Information SystemsCommented:
Of course, but IIS doesn't care what the folder is called.  You can take the existing folder, rename it, create a new folder with the old name, and publish to that.  No change to IIS required.
0
Thomas GrassiSystems AdministratorAuthor Commented:
That sounds good

Just sent you a message too
0
Thomas GrassiSystems AdministratorAuthor Commented:
Paul

Good news  the renaming worked the site is working now no 401 errors

Just can not get the WebDAV working any ideas?
0
Paul MacDonaldDirector, Information SystemsCommented:
What error does WebDAV give you?
0
Thomas GrassiSystems AdministratorAuthor Commented:
Paul

I am using Microsoft Expression Web 4

when I try to publish I get this message

The web server does not appear to have any authentication methods enabled. It asked for user authentication but did not send www-authenticate header.


I IIS  under sites I have
Default Web Site  port 80
SharePoint - 80
Music    port 80

I enabled WebDAV on Music and default Web site
Added my user id to the WebDAV Authoring Rules with  Read, Write Source access


Authentication on both default web site and music sites have Anonymous Authentication enabled.


Thoughts?


Note


This was all working yesterday even after I added the Windows Authentication method to both sites

But after that was done I was getting the 401 error So the Windows Authentication method is a problem
0
Thomas GrassiSystems AdministratorAuthor Commented:
Paul

A thought

I made the same changes to my Default Wed Site as I did to my Music site with the authentication settings

I added Windows Authentication on both sites

Can I add Windows Authentication to the default site without effecting the Music site?

We removed the music site and recreated it and that fixed the 401 errors

but I am still not working with WebDAV

can I recreate the default web site too?

I am stuck here not being able to publish my pages on the site

Thanks
0
Paul MacDonaldDirector, Information SystemsCommented:
"Can I add Windows Authentication to the default site without effecting the Music site?"
Not knowing how these are configured, I can't say for sure, but it's very likely you can.

"can I recreate the default web site too?"
Yes, and that's what I initially suggested.

Is there anything in Microsoft Expression Web 4 that defines the sort of authentication it uses?  The problem may be on your end as well as on the web server's end.
0
Thomas GrassiSystems AdministratorAuthor Commented:
Paul


Microsoft Expression Web 4 jut has site settings where you enter the  name Connection type (WebDAV) Location
http://wwwmysite.com/webdev
Credentials
user name and password

How would I go about removing the default web site?
I think it is a reserved name and I can not rename it or remove it

Just had a thought I am going to remove the virtual directory I created under the default site and recreate it

Will post later
0
Thomas GrassiSystems AdministratorAuthor Commented:
Paul

That did not work either

I checked my old web server (windows 2003 IIS 6

On both sites under Directory Security > Authentication and access control

Enable anonymous access was checked
user account was IUSR_SERV012

Authenticated access
Integrated Windows authentication  was checked.

Now in IIS 8 this has changed?

Authentication    Anonymous Authentication is enabled

Where is access control?

Am I missing something here?

Thanks
0
Thomas GrassiSystems AdministratorAuthor Commented:
401 error resolved by recreating the site.

Opening new question for the WebDAV issue


Thanks
0
Thomas GrassiSystems AdministratorAuthor Commented:
0
Thomas GrassiSystems AdministratorAuthor Commented:
Paul,

Got it working

found this and followed the instructions needed to enable windows authentication on the default site for WebDAV to work.

http://www.iis.net/learn/install/installing-publishing-technologies/installing-and-configuring-webdav-on-iis

Thanks for your help
0
Paul MacDonaldDirector, Information SystemsCommented:
Thank you for the points!  I'll look at the other thread.
0
Thomas GrassiSystems AdministratorAuthor Commented:
Paul

No need I closed that thread last night since I fixed it

Thanks again for your help
0
Paul MacDonaldDirector, Information SystemsCommented:
Glad to hear you're working again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.