Access denied after installing Microsoft LifeCam HD-3000

OS: Windows 8.1
Device: Microsoft Life Cam HD-3000

Was working perfectly for 6 months or more. Not sure what event triggered it not working but system stopped recognising device. All other USB devices work.
Camera works in all other computers tested.

Device Manager reports device as Unknown.
Update driver - completes and shows Device is recognised - but device does not show up in WebCam enabled apps. Unplug and reconnect and device is again reported as unknown.

Go back to Device Manager - and look at properties for WebCam the following message is displayed.
After installation DM reports
"This device is not configured correctly (Code 1)"
With "Access Denied" under it.

After reconnecting the message changes to
"The drivers for this device are not properly installed (Code 28)"

Repeating the above does nothing.

Have also tried deleting the USB UpperFilters and LowerFilters - also no joy.

Any ideas?
LVL 66
Julian HansenAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

☠ MASQ ☠Commented:
Try installing on another machine first to check the hardware is still OK.
Julian HansenAuthor Commented:
@MASQ,

Thanks for the response - refer quote from my original post
Camera works in all other computers tested.
☠ MASQ ☠Commented:
Then try  System Restore to a date prior to this happening.
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Julian HansenAuthor Commented:
Thanks MASQ unfortunately that is not an option.

This is obviously something to do with a bad registry or permissions problem (or similar) was hoping someone out there had the same problem and was able to fix.
nobusCommented:
i would install the latest driver for the camera first

check also event viewer for errors - it may show the cause !
Julian HansenAuthor Commented:
i would install the latest driver for the camera first
We have done this several times - it is a Microsoft Product - it finds the latest drivers - that does not seem to be the problem. Something in the system is preventing those drivers from being installed properly - which I suspect what the access denied message is saying - however there is not enough information to say where the access issue is.

These seems to be a common problem with Vista / 7 / 8 - I have found several posts with suggested solutions being the obvious but nothing that says what the root cause or solution is (short of re-install).

We have even tried systematically uninstalling all applications one by one and testing after each - to see if that makes a difference.

We think it is registry related - there was an incident with this machine where a registry key permissions were changed and we could not change the permissions back - but we did resolve that. It is possible that something in that process caused a problem - however to find what key / value it is ... was hoping someone out there had more information.
nobusCommented:
i also posted "check also event viewer for errors - it may show the cause ! "  did you run it yet?
Julian HansenAuthor Commented:
have checked - but will check again. Too many entries to go through but will time stamp it and attempt another install and then check again.

One error that I did notice comming up a lot was
The application specific permission settings do not grant Local Activation for the COM Server application
On the RuntimeBroker (mainly - there were a few others as well).
Attempting to reset permissions through dcomcnfg was not successful - all options are greyed out (logged in as adminstrator).
☠ MASQ ☠Commented:
"We think it is registry related - there was an incident with this machine where a registry key permissions were changed and we could not change the permissions back - but we did resolve that. It is possible that something in that process caused a problem"

"Attempting to reset permissions through dcomcnfg was not successful"


This is helpful - can you explain more about what happened?  Malware/file corruption?  What fixed it for the entry you had to alter previously?

Yes, a locked registry key is likely at the bottom of this and it's easy enough to identify all the locations the webcam install writes (or attempts to write) to but less easy to find the locked key(s)

It sounds like you've already been through the MS KB article on Logitec webcam conflicts - although this isn't likely to be useful given it was working fine until recently.
Julian HansenAuthor Commented:
We don't know what caused it. There were several possible culprits - one of them was possibly the KeyLemon face recognition login addon for Windows (which has been removed - but did make use of the webcam).

One possible next step is to setup regmon and filemon during the install and then wade through the gust of the output from those to see where it tried and failed - being a developer and lazy by definition I thought it would be quicker to do it this way ...
☠ MASQ ☠Commented:
Good plan
I was thinking RegShot on another machine to grab all the entries that change on install, then, once you have a list, writing a Reg file that removes all those entries (basically putting a "-" in front of the RegShot file entries) and again waiting to see where it fails because of permissions.  Not quite as lazy but I'm getting there :)
nobusCommented:
>>  Too many entries to go through   <<  you know how to filter for errors ?
Julian HansenAuthor Commented:
@nobus,
you know how to filter for errors
Yup but even after filtering there are a bunch of different error entries relating to a variety of issues that do not seem related to this issue. What I meant was going through each error event and researching each one to find out if it is connected to this problem or not - the only one that seems vaguely related is the RuntimeBroker failing to start - while I can't see any relation to this and the installation of a WebCam (other USB devices are fine) - I am hoping that by solving that it might also solve the other issue.
Other than that only potential culprit remains the KeyLemon software.

@MASQ - will look at doing a reg delta on a clean install to see what keys / files are targeted and check those out.

These were all part of plan B after exhausting the "experience out there" option.
nobusCommented:
>>   that do not seem related to this issue   <<  don't exclude them too fast

one service failing  can stop others, or drivers - giving birth to un related errors
Julian HansenAuthor Commented:
>>> one service failing  can stop others, or drivers - giving birth to un related errors

Yes I know - as I mentioned before - before diving into the deep diagnosing pool I first wanted to poll the community to see if there was a known / easy / simple solution to sort this out. Someone with more knowledge of MS Driver architecture than I have to point me in the right direction.

If nothing is forthcoming the next step is to go deep and look at all the errors, RegMon, Install Delta's etc - all of which are extremely time consuming - and therefore a last resort.
nobusCommented:
then it was likely an update
can you uninstall the latest ones?
Julian HansenAuthor Commented:
We have tried that as well - there are two machines here that are practically identical - same updates but one has extra software on it (the problem one) - the extra software has been removed and we have tried regressing some of the updates to before the problem but it persists.

I am going to do the registry analysis approach - something has been broken somewhere and is outside the normal install / uninstall process - to find it (given there is no specific solution out there) is going to require some in depth analysis.

Will do this next week and report back.
nobusCommented:
>>  extra software   << if you suppose that's the cause do a search for it on the registry, and delete all keys
remember to have a registry backup first
personally -i use regseeker for this, since it shows all keys in 1 search  http://www.hoverdesk.net/                        Regseeker
Julian HansenAuthor Commented:
and delete all keys
remember to have a registry backup first
Don't understand - a driver install requires its own set of keys and settings - deleting keys relating to an installed app should have no effect.

We are busy checking through the c:\windows\inf\setupapi.dev.log files and comparing on the two computers.

Currently we notice that on the one it exits successfully the second with Error 0x0000005 (Access denied)

ProcMon - so far has shown us nothing - but that is more because of information overload - busy working out filters to apply to strip out the non-necessary stuff.
☠ MASQ ☠Commented:
Apologies if you've already got this but suggest you set ProcMon with only Registry Activity toggled on (i.e. switch off all the defaults on the toolbar) and add the filter "Result IS ACCESS DENIED Include".
Only monitoring Registry Activity selected - plus filter for Access Denied
Then run the installer again and log the output.
Julian HansenAuthor Commented:
Thanks MASQ - I am an old hand at ProcMon and RegMon / FileMon before it.

As I said this thread was an attempt to find a shortcut as I don't really have time to do the long version but will if necessary.

I really appreciate all the comments in this thread - the discussion is helping to focus on where the problem might be and it will be good to get it off my todo list ...
Julian HansenAuthor Commented:
Apologies for the lateness of the reply - after many hours looking at RegMon / Filemon output and getting nowhere we updated to Windows 10 and that seems to have resolved the problem.

Thanks all for the responses.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Julian HansenAuthor Commented:
Unable to solve issue
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.