SharePoint 2013 + BDC - No search results to display, but correct result count

I am trying to set up SharePoint 2013 to expose an external department directory through search. I've followed or consulted several guides online, including the one below. I've double and triple checked the steps, but I am definitely missing something.

In short, I can see the data that the BDC is exposing on the External Content Type profile page. I have mapped the crawled properties to the managed properties. I've added a result source that just returns all of the data in the content source I created just for this BDC entity. I added that result source to a Search Results web part and left it unfiltered. I see 2,298 results (exactly the number) but I also see that there were no matches for my search.

Result count, but no results!
I configured two fields to be refiners, and both of those appear in the refinement options I have on this results web part. It even shows the first 5-10 values from both fields! Yet, there's nothing to show me. I created Result Type to fire on this content source and then assigned a nearly empty Display Template to it - it will simply display the word 'hobo'. Still nothing.

I don't know what details to provide because I don't have a clue what I missed. Please let me know what information you need to help and I will provide all that I can! Does anyone know what might be going on here? Any idea where to start would be appreciated.

Josh
LVL 1
Josh PriceApplication EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohit NairSenior AssociateCommented:
Is your site search working ? Or is it just the BDC integrated properties not visible.
0
Josh PriceApplication EngineerAuthor Commented:
Sadly, I have just found the source of the problem and it makes me look like quite the moron. I've set up several search pages before, but while setting these ones up, I decided it best to uncheck both Ranked Results and Promoted Results in the web part settings. Obviously, you need one or the other. In my case, Ranked.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Josh PriceApplication EngineerAuthor Commented:
Everything was configured correctly from the SQL database permissions, to the BCS entity, to the content source in search. What made this appear to not function was unchecking the Ranked Results option in the Settings menu of the Search Results web part. I had unchecked both Ranked and Promoted, but you need at least one of them checked to display results.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.