.chm files note opening

Experts:

I have an application that's running off of a network share and I'm unable to view the help files from within it. I've tried the following popular responses:
- unblock the .chm file (it wasn't blocked)
- add the registry key explained in this MS KB: http://support.microsoft.com/?kbid=896054 and adding my network share to my trusted sites in IE. This allows me to view the pages of the help file when I open it from my network share but not from the application.

Anything else you can suggest trying?

Thanks in advance,
telliot79Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Duy PhamFreelance IT ConsultantCommented:
It sounds like problem with the application you use, not the problem with the network sharing security or the .chm file itself.

What if you copy the application to your local machine (including the help file), and then run it from local machine. Could it open the help file?
0
telliot79Author Commented:
Thanks for the quick response.

It's happening for two of my applications.

for the first, app1, I've ran the application from the actual folder, not the share, and it now allows me to see the contents of the help files. For app2, I doesn't. However, within app2 there are a number of configuration settings that point to the network share, so this may not be a valid test.

copying the apps and help files locally isn't really an option for a fix in my case unfortunately.
0
Duy PhamFreelance IT ConsultantCommented:
I understand that you want to run your applications from network share. My point was just to guess the cause of the issue, which lies in application, not in neither .chm file or network share security.

I don't know how your applications are made, so it is hard to tell why except that I believe the problem is due to the way those applications are developed. If you make it, maybe you should try to log/debug it yourself (e.g.: application 2 with configuration options).

Have you tried to map network share folder to a drive (e.g.: Z:\), and try to run those applications from mapped drive?
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

telliot79Author Commented:
I don't think it's to do with the applications themselves, they're corporate apps that are used by millions I'm sure. It's a windows problem, due to vulnerabilities on chm files and IE.

Have you tried to map network share folder to a drive (e.g.: Z:\), and try to run those applications from mapped drive? - this is exactly what we're doing.
0
Duy PhamFreelance IT ConsultantCommented:
We haven't run any application directly from network share folder before, so I just tried to guess upon your description. You can open .chm file directly from network share folder, it means your user profile does have enough permissions/privileges to read that file, and hence I'm supposed that any application running under your user profile (your account) will have the same permissions too.

We have been using mapped network share folder for more than five years, and our application can open Office files using embedded ActiveX (which could also be considered as vulnerable as chm files) from network share folder just find (of course when running locally). The only known issue so far we have encountered with network share Office files is that sometimes embedded Office application (such as Word/Excel) crashes when opening a template file from network share folder. But that's out of our hand, so we have to live with that.

I don't know whether it's related, but have you looked into this description from MS: https://support.microsoft.com/en-us/kb/896054?
0
help-infoCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
telliot79Author Commented:
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.